summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-31 09:59:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-31 11:58:34 +0100
commit5d3130564bb38c017c74033ad84c90d3f78232d7 (patch)
treecb170b3929b90d441b56d1d7927e914d2a423404 /dev-python
parentnet-dns/dog: block sys-apps/dog due to file collision (diff)
downloadgentoo-5d3130564bb38c017c74033ad84c90d3f78232d7.tar.gz
gentoo-5d3130564bb38c017c74033ad84c90d3f78232d7.tar.bz2
gentoo-5d3130564bb38c017c74033ad84c90d3f78232d7.zip
dev-python/virtualenv: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/virtualenv/Manifest1
-rw-r--r--dev-python/virtualenv/virtualenv-20.1.0.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 82d9a61fd688..ab5fc560cde5 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,3 +1,2 @@
DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecdcbb0821efdd94ca324a8cc34a68a760a8a98de97f0cb2384d8e6cbb0ce8f261995c6433886444e29b75ba0ce09ca12c SHA512 f06d7c354ce1910f04dbcbe1a77e60392653bbe4f638bafbe9284454db2c0e5d63cf9159201d0916fc01aaba91d45fb733b63096c38517fcd83fd00ed8b26d28
-DIST virtualenv-20.1.0.tar.gz 8284462 BLAKE2B 4356c9c49f7bd2dbb6cf8998be5cd3970804bdec5e3c1223439700f4b5597cd843cdb17b722d54f0181094296247d1f2d4c27980679602b94020fdf1e95dd73f SHA512 740bf8ba30d836c240d248dd2fa31a8702cfa8f96a6192dd6430dbeff3ebbf0fe67d4fd2439ed4961869731520b097783a29381eae3f81f6700b6050b75422c8
DIST virtualenv-20.2.1.tar.gz 8286055 BLAKE2B da77c51b352e979f05515107df49101a70f97da01862ae92aff0e185065edf1d6d517ee68057f1f2efe5ee999dd9dec24c0f2967b1f10130b446e83e478ccbd1 SHA512 e7877a9766bc47f47a07219258201ad8457ca587a04d61119a0516da43016dda4b5cfeaf725dd0b06f1f896ac8af0f3d7a2ceed3d3f35ac7a4b6ecc607c84118
diff --git a/dev-python/virtualenv/virtualenv-20.1.0.ebuild b/dev-python/virtualenv/virtualenv-20.1.0.ebuild
deleted file mode 100644
index 6a3cdc836d9e..000000000000
--- a/dev-python/virtualenv/virtualenv-20.1.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=manual
-
-inherit distutils-r1
-
-DESCRIPTION="Virtual Python Environment builder"
-HOMEPAGE="
- https://virtualenv.pypa.io/en/stable/
- https://pypi.org/project/virtualenv/
- https://github.com/pypa/virtualenv/
-"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
- >=dev-python/distlib-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
- ' python3_{6,7} pypy3)
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-1.0[${PYTHON_USEDEP}]
- ' python3_6 pypy3)"
-# coverage is used somehow magically in virtualenv, maybe it actually
-# tests something useful
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-5[${PYTHON_USEDEP}]
- >=dev-python/pytest-freezegun-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- ' 'python3*')
- )"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme \
- dev-python/towncrier
-
-src_prepare() {
- # we don't have xonsh
- rm tests/unit/activation/test_xonsh.py || die
- # require internet
- sed -e 's:test_seed_link_via_app_data:_&:' \
- -i tests/unit/seed/embed/test_boostrap_link_via_app_data.py || die
- # TODO: investigate
- sed -e 's:test_cross_major:_&:' \
- -i tests/unit/create/test_creator.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- if [[ ${EPYTHON} == pypy3 ]]; then
- # TODO: skip with better granularity
- ewarn "Skipping broken tests on pypy3"
- return
- fi
-
- distutils_install_for_testing
-
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- elog "Please note that while virtualenv package no longer supports"
- elog "Python 2.7, you can still create py2.7 virtualenvs via:"
- elog " $ virtualenv -p 2.7 ..."
-}