summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-11 09:22:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-11 09:49:12 +0100
commit5da29cc8e41ff9e951803d34195f6fef87034c9e (patch)
treeed87f9f32e2648b3623ddd81c75846d5ca5c1f65 /dev-python
parentdev-python/jeepney: Bump to 0.5.0 (diff)
downloadgentoo-5da29cc8e41ff9e951803d34195f6fef87034c9e.tar.gz
gentoo-5da29cc8e41ff9e951803d34195f6fef87034c9e.tar.bz2
gentoo-5da29cc8e41ff9e951803d34195f6fef87034c9e.zip
dev-python/botocore: Bump to 1.19.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.15.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ce7a3723cdd3..1c33aa1d25bf 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,5 +6,6 @@ DIST botocore-1.19.11.tar.gz 6981193 BLAKE2B 8e7c799faef989817ce4cfbe26c359af0a8
DIST botocore-1.19.12.tar.gz 6985286 BLAKE2B f65a416ecae9911899dc16411cc80a968e343531f43ded1b7f4c546df59d8f2cbb93d6027d07a267831ce71d27b53b9ac61ced2d91b69c94c344bed0167c64d7 SHA512 94d0d56dd5dc0c3dd3c28b6d9deb47949420778cbfaa30829db6a2787f3d8088327cb0194b920cee0598d7fc28936c4c0e532874449024485b27a06bf03982df
DIST botocore-1.19.13.tar.gz 6985490 BLAKE2B 2da3b5840c18e7ec1bcdf9b535defc9ba5d1b0990febdbc6bfbe3aaadfb81b754d2a9df76aa3978279dee22af35a50da6cda186d1d632403dbb60208fec216f5 SHA512 74323c87a9a6e6009862d11f5e96dfb5d2cde282aca206a1703038f001d926d282fdb6cce9085c8645bc4e1b2cff1666cbf013a508b3aa3cb598cdd74c476b6b
DIST botocore-1.19.14.tar.gz 6996482 BLAKE2B ff5b977254fad5af2ec5129e0bb3ceafc071389a7f389f0da7f43b978804f1ecc4db303009611619be24318d4ff2eb2e109f00cea6438b8ae670ba572f3e0862 SHA512 546dea8b1ca588f055b0adbdb0602e5eaf5cfe094374379972a2323b809bb231974af61b66efe2c8ac7f33972200c9272464b13297fedf1b7bdbe68231678cd5
+DIST botocore-1.19.15.tar.gz 6996595 BLAKE2B 562bb257f481a5668d25c99a4a6d27bff6f50e3fda68cbc09ef40bc6a86fafa95de1206828f0903aba3042b8bd5ab7c8a5ebde4c93ee3be54d3175ab5bf588b7 SHA512 d0d63edae759dd865d54ffb635c79fededbdba9a4147b3008f2aa41a19dd674a5d780d9a6006db33b0ec53a5278fd393dbe483a4a491d96e1fada5cf26be0c53
DIST botocore-1.19.8.tar.gz 6970481 BLAKE2B 52d3f8ee7dc38feddb3f7799959624b4baf4b75ebcf3ad8257c25ad13b8a8c3cf526ee187681b6d8f5f6ee874071a02c59bd106cb4b4e23ad9cf13b9aa74deef SHA512 845dfec33f63deee44bfffe81801995bfcc2014880c2d520b927421219279107b0fe44dc84425c0a55ddec73d5ad8aeb34f2b84178e1365d137240a2e94370c7
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.15.ebuild b/dev-python/botocore/botocore-1.19.15.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.15.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}