summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-11 16:31:33 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-11 16:31:33 +0200
commit5eb74d6cda402ce25804ed6f5f56f3bfb85db8e5 (patch)
treecf1f86b30d27f5aa6c47f64e93e65e28b5c8360e /dev-python
parentdev-python/pyvirtualdisplay: add version 2.2 (diff)
downloadgentoo-5eb74d6cda402ce25804ed6f5f56f3bfb85db8e5.tar.gz
gentoo-5eb74d6cda402ce25804ed6f5f56f3bfb85db8e5.tar.bz2
gentoo-5eb74d6cda402ce25804ed6f5f56f3bfb85db8e5.zip
dev-python/qstylizer: add version 0.2.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qstylizer/Manifest1
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
index f1956f81d591..bb9ebc356aae 100644
--- a/dev-python/qstylizer/Manifest
+++ b/dev-python/qstylizer/Manifest
@@ -1 +1,2 @@
DIST qstylizer-0.1.10.tar.gz 20683 BLAKE2B aa12addac6cbe1ebf043d70189683feda87db3a8c2aa3604a04a969f638647ba32eaf7d156559b8af151136aaca784f26025746d9f3e574ad6eb777801bcf44a SHA512 1a747c2a0d5ce0acd220f528bc54c84c723f50bf39fc8d818f6a5475105319f46700d2f00bc5c0f14de8f0caaee0ab8904a379a3e697ca68d00ef62ec3408b2b
+DIST qstylizer-0.2.0.tar.gz 20710 BLAKE2B 1d751efd74e36e665823b64cfd51760bea489ac3916b7ab206d9c9f1fe9adbc0df2dfd9666a79e20c805dabcaa6f3cf4d11074943e0a54b7a6aa93a815c796cf SHA512 094d9c9c14d2000c2c2f2b428cd82a57424507c6df83aa21af3ab7b90e9006761ed131262a2e70a1c4aa4dcea87ac6d07f9137bc224967139467b3f4796ab158
diff --git a/dev-python/qstylizer/qstylizer-0.2.0.ebuild b/dev-python/qstylizer/qstylizer-0.2.0.ebuild
new file mode 100644
index 000000000000..284ba9373687
--- /dev/null
+++ b/dev-python/qstylizer/qstylizer-0.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
+HOMEPAGE="https://github.com/blambright/qstylizer"
+SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/tinycss-0.4[${PYTHON_USEDEP}]
+ <dev-python/tinycss-1[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/inflection-1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-vcs/git
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-autoprogram
+
+python_prepare_all() {
+ # Exception: Versioning for this project requires either an sdist tarball, or access to an
+ # upstream git repository. It's also possible that there is a mismatch between the package
+ # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
+ # was given, but was not able to be found.
+ #
+ # There are no tarballs on PyPI, so we do this as a workaround
+ git init -q || die
+ git config user.email "larry@gentoo.org" || die
+ git config user.name "Larry the Cow" || die
+ git add . || die
+ git commit -mq "init" || die
+ git tag -aq "${PV}" -m "${PV}" || die
+
+ distutils-r1_python_prepare_all
+}