summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-11 08:34:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-11 08:53:12 +0200
commit5ed0834097ef2debc6825d0f6d411e5b1eda0fc8 (patch)
tree40741e0e23c6bcfca56343d4575383ee605b2e5a /dev-python
parentdev-python/responses: Bump to 0.14.0 (diff)
downloadgentoo-5ed0834097ef2debc6825d0f6d411e5b1eda0fc8.tar.gz
gentoo-5ed0834097ef2debc6825d0f6d411e5b1eda0fc8.tar.bz2
gentoo-5ed0834097ef2debc6825d0f6d411e5b1eda0fc8.zip
dev-python/autoprop: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/autoprop/Manifest1
-rw-r--r--dev-python/autoprop/autoprop-4.0.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/autoprop/Manifest b/dev-python/autoprop/Manifest
index 0a786c30ba92..87d8ed810a46 100644
--- a/dev-python/autoprop/Manifest
+++ b/dev-python/autoprop/Manifest
@@ -4,3 +4,4 @@ DIST autoprop-2.1.0.tar.gz 13258 BLAKE2B a08431a87067463278276974326ca81a8c01501
DIST autoprop-2.1.1.tar.gz 13794 BLAKE2B 63645d0d8f9d49f5df730dca18c468e3dea7108e01cf12f6de6d80ad6cf8b5d396957d4a0cd82c737c0b12274a8534e6f48120ef1118c0fb34dba529dc74f081 SHA512 39db6c1130d0b958713f15efcd75ecbbb41659f5f7182be37f1dca22a46c18832d0f7893fadfbf4e8ad9f446417a2476e7dc7890124c9caabd6b5dde37eb7c6f
DIST autoprop-2.2.0.tar.gz 13939 BLAKE2B b30565618cab67c5a3b9f94958a8f4734d60c048067f73a007fdb9d34555337f92776cac221c89e0067851d59b21f157b4bc1d24fdcaf3e3ae677c31c8a32cc9 SHA512 d8ef758b0d097ddb73cb384075d3d2b0d59191cd12d59a54cc449483da94ab116c75b39cf48d3d262b147e855af1806a0c617ba220f435118d636cd6f283c51e
DIST autoprop-3.0.0.tar.gz 14082 BLAKE2B 9881dd924b8d66e83dccb3e7ca1d753bec924e8f348d96d0522a76e857c85311ef7ada37b0080c1b3a0e719bf84e807d12c7e4dff4bbfc111273b340f92244a5 SHA512 4730155130b98fc02bea991837ee6d875f19ffa14ae542909314264950d20a34cdbff9e21b31431136624de0dac5eb2a50a9cf677da01862b38cae9c10bec92f
+DIST autoprop-4.0.1.tar.gz 19998 BLAKE2B aefff2e8f1d583c45e77a2b0530a07e03be9229977f9f1229cfd832f609d2f31d4cd05ad741189ceb7a01d846e286c85158439952e587dd007526794c6b9a993 SHA512 d77caec360f59f247cd23a1636771808bdcbaa6ba96241cafeabc144e88975b607b604800d2d374c5b6f80b68bf631ab74278c19fe1544112a6c6813190c744f
diff --git a/dev-python/autoprop/autoprop-4.0.1.ebuild b/dev-python/autoprop/autoprop-4.0.1.ebuild
new file mode 100644
index 000000000000..705c1c240973
--- /dev/null
+++ b/dev-python/autoprop/autoprop-4.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/signature_dispatch[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest