summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-08-06 22:55:09 +0200
committerRafael Martins <rafaelmartins@gentoo.org>2016-08-06 22:55:09 +0200
commit6009c41728f7afe3072ebfe70b0fac4e43d22a96 (patch)
tree5565c5b049d1622a9c942637e79f23508c484e8e /dev-python
parentapp-eselect/eselect-lua: add myself as maintainer (diff)
downloadgentoo-6009c41728f7afe3072ebfe70b0fac4e43d22a96.tar.gz
gentoo-6009c41728f7afe3072ebfe70b0fac4e43d22a96.tar.bz2
gentoo-6009c41728f7afe3072ebfe70b0fac4e43d22a96.zip
Initial import
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ethtool/Manifest1
-rw-r--r--dev-python/python-ethtool/files/python-ethtool-0.11_include-net-if.h-for-IFF_-macros.patch24
-rw-r--r--dev-python/python-ethtool/metadata.xml13
-rw-r--r--dev-python/python-ethtool/python-ethtool-0.11.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/python-ethtool/Manifest b/dev-python/python-ethtool/Manifest
new file mode 100644
index 000000000000..0da9e9a9a015
--- /dev/null
+++ b/dev-python/python-ethtool/Manifest
@@ -0,0 +1 @@
+DIST python-ethtool-0.11.tar.bz2 34487 SHA256 686756e4b2b239319e8513025debcc0d97103815b0879f94d8234cbbca6ada24 SHA512 b260e608e1024c48eedb72327b704b01fb42396219ca3d942fe42f22d3e8018fc74bfeffd96e37abd4efd2ce49a73915e0e2af5841a537a02e247d4ba5548f20 WHIRLPOOL 1bb2dc8718fd418f81aa20960712f5c2bd131a1128c291df5e955fef83ea71035f429b0fb9e9d213488b0129631978e7fd48f41b199195c59efa30b91484005a
diff --git a/dev-python/python-ethtool/files/python-ethtool-0.11_include-net-if.h-for-IFF_-macros.patch b/dev-python/python-ethtool/files/python-ethtool-0.11_include-net-if.h-for-IFF_-macros.patch
new file mode 100644
index 000000000000..f5cb92984ef9
--- /dev/null
+++ b/dev-python/python-ethtool/files/python-ethtool-0.11_include-net-if.h-for-IFF_-macros.patch
@@ -0,0 +1,24 @@
+From a43f582918d3295b7cdef9e056bf5b1c4eb2ef80 Mon Sep 17 00:00:00 2001
+From: Yaakov Selkowitz <yselkowi@redhat.com>
+Date: Mon, 22 Jun 2015 05:18:44 -0500
+Subject: [PATCH] Include net/if.h for IFF_* macros
+
+---
+ python-ethtool/ethtool.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/python-ethtool/ethtool.c b/python-ethtool/ethtool.c
+index 0f9cdbb..5415ec6 100644
+--- a/python-ethtool/ethtool.c
++++ b/python-ethtool/ethtool.c
+@@ -27,6 +27,7 @@
+ #include <sys/types.h>
+ #include <ifaddrs.h>
+ #include <netlink/route/addr.h>
++#include <net/if.h>
+
+ #include "etherinfo_struct.h"
+ #include "etherinfo_obj.h"
+--
+2.1.0
+
diff --git a/dev-python/python-ethtool/metadata.xml b/dev-python/python-ethtool/metadata.xml
new file mode 100644
index 000000000000..112c4c091ce3
--- /dev/null
+++ b/dev-python/python-ethtool/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python bindings for the ethtool kernel interface, that allows querying and
+ changing of Ethernet card settings, such as speed, port, auto-negotiation, and
+ PCI locations.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-ethtool/python-ethtool-0.11.ebuild b/dev-python/python-ethtool/python-ethtool-0.11.ebuild
new file mode 100644
index 000000000000..810f7fb80220
--- /dev/null
+++ b/dev-python/python-ethtool/python-ethtool-0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+# TODO: install scripts and their man pages
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Ethernet settings python bindings"
+HOMEPAGE="https://fedorahosted.org/python-ethtool/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libnl:3"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_include-net-if.h-for-IFF_-macros.patch"
+ distutils-r1_src_prepare
+}