summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-23 11:42:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-23 11:42:31 -0500
commit61759eec45c53860170967d4e9ab89f5346d7c56 (patch)
treea8a04275d15dc6d514cf91b2ad57ceb6c689f0a8 /dev-python
parentnet-analyzer/wireshark: ia64 stable wrt bug #682918 (diff)
downloadgentoo-61759eec45c53860170967d4e9ab89f5346d7c56.tar.gz
gentoo-61759eec45c53860170967d4e9ab89f5346d7c56.tar.bz2
gentoo-61759eec45c53860170967d4e9ab89f5346d7c56.zip
dev-python/pecan: use python_gen_cond_dep for py27 deps
Fixes: https://bugs.gentoo.org/692448 Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pecan/pecan-1.3.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pecan/pecan-1.3.3-r1.ebuild b/dev-python/pecan/pecan-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..e8f8563568b2
--- /dev/null
+++ b/dev-python/pecan/pecan-1.3.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"