summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-05 08:44:10 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-05 08:45:11 -0400
commit620b18a6a84d4553698391273ed91534d20d0920 (patch)
treedf5c340c5c0c403ea3ef3026bd3c58f7af045dfa /dev-python
parentapp-emulation/lxc-templates: bump to 3.0.2 (diff)
downloadgentoo-620b18a6a84d4553698391273ed91534d20d0920.tar.gz
gentoo-620b18a6a84d4553698391273ed91534d20d0920.tar.bz2
gentoo-620b18a6a84d4553698391273ed91534d20d0920.zip
dev-python/python3-lxc: bump to 3.0.2
with some delay... Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python3-lxc/Manifest1
-rw-r--r--dev-python/python3-lxc/python3-lxc-3.0.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python3-lxc/Manifest b/dev-python/python3-lxc/Manifest
index b6e6418b6d81..41fdf70d941c 100644
--- a/dev-python/python3-lxc/Manifest
+++ b/dev-python/python3-lxc/Manifest
@@ -1 +1,2 @@
DIST python3-lxc-3.0.1.tar.gz 27424 BLAKE2B ffdf128e06d7b256652588af7c464045479ce907d2119dfe9780737c7bd5f3008c01d834a79f63932bfa51e3094a9d40af46c4cb6c3be72108205d65a8ee3d11 SHA512 7e6b6cb9a02e5af8b3fc8aeefff2954c68d2d1154751fa97a70bce86131021571e15db86bb0d6900a93dda78247e37b75cdfe250bf4d1b7548dc8383ed3d45f6
+DIST python3-lxc-3.0.2.tar.gz 27300 BLAKE2B dc4ba71b156eb0f257bf9d717f07f22afee3d00666601b709341d9091a1a75d237c174f613a93b6ecf7c69b4e6cc75187316e656a02a1d52f0e9970b8f3af6ad SHA512 2fc776decf6248be39f9e8a607a967acf180f3a07e45fadd6be4450f01caa4a854f217dcf7e81e27b5b838c2cea04ef09c8ab8b87c5be5091185bba2eb6b6d23
diff --git a/dev-python/python3-lxc/python3-lxc-3.0.2.ebuild b/dev-python/python3-lxc/python3-lxc-3.0.2.ebuild
new file mode 100644
index 000000000000..2f5864cdfceb
--- /dev/null
+++ b/dev-python/python3-lxc/python3-lxc-3.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxc/"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-emulation/lxc-3.0"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"