summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 09:12:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 10:00:06 +0200
commit6248a60514d79b29c3c4142613725c7859433c4f (patch)
tree74eadbc491518e3f72041748f436b2fcb4afd81c /dev-python
parentwww-client/vivaldi: Old (diff)
downloadgentoo-6248a60514d79b29c3c4142613725c7859433c4f.tar.gz
gentoo-6248a60514d79b29c3c4142613725c7859433c4f.tar.bz2
gentoo-6248a60514d79b29c3c4142613725c7859433c4f.zip
dev-python/wcwidth: Bump to 0.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcwidth/Manifest1
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index ac43b2663046..6c3ac689e936 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -2,3 +2,4 @@ DIST wcwidth-0.1.8.tar.gz 19957 BLAKE2B dd4ba31bec5161a9509b0ef7e73901c3ff31b2ce
DIST wcwidth-0.1.9.tar.gz 24764 BLAKE2B c7a5a50a8628649810dddd37b1af4c7ea52b2d0d2e516bd24e04675849e6f402e6ef4b7cea0fb507c5446b455d8725f497771bb30cd4d7eafa90cbb6fc2d01b4 SHA512 3aee69efb8714f4426bfd424b80f4f4e5758174d84f725dd0e1448de1b4b4dd385ffd4f72440d5f763b7a82325857e9164742dbb7fa9e15d5db54744c262d0ba
DIST wcwidth-0.2.2.gh.tar.gz 46929 BLAKE2B 8dac0a793417b04aaccd2235bdd3dee30e18b068a41e515934d2e7b6efb354039adba767db011a2782c9e1f5b8d2568f4ef73ae09361bf8f608491d252bccc21 SHA512 e644a8f83ac5974174e7dae35784c4f9310e39fcfd49d98d6da0f59efd19a0734d5c65e252689843346eb6adad62edfef76658648b34779191fbcf0655188d52
DIST wcwidth-0.2.4.gh.tar.gz 47355 BLAKE2B 152befc1f9e8630f407a78c70c9121dcbf27a9bc165ef82ec80a6e0793eda5fa89829542dc14959eedf9cc7676edb0212b29bac95c8f041b9f007d03d2a05852 SHA512 69123170421f7f37a9d09e44860cace29b303701b7be8941d7af403b0f4044b273c136da5726689f13c061587fda24f944ef1da918712bed0eda8c00c7a208c0
+DIST wcwidth-0.2.5.gh.tar.gz 47514 BLAKE2B 0ac5fb08283c23039453408da2edac36e2079fde8fc903002785e2e0f8bed55d1d6a291181097f73e4ec8152b6eaa4f4553b0b39fe1cadc7a99bacb2d7e55d2c SHA512 3f1f1fefd3ee9f06ea2051842e8c3bb09a92501f031124b8514bec444eaa8594ab9649534b4264340d475716d5a6571dbe5ae932f685160defd75c19295e60f9
diff --git a/dev-python/wcwidth/wcwidth-0.2.5.ebuild b/dev-python/wcwidth/wcwidth-0.2.5.ebuild
new file mode 100644
index 000000000000..00627f52df55
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="
+ https://github.com/jquast/wcwidth/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ ' -2)"
+
+distutils_enable_tests pytest
+
+DOCS=()
+
+src_prepare() {
+ sed -e 's:--cov-append::' \
+ -e 's:--cov-report=html::' \
+ -e 's:--cov=wcwidth::' \
+ -i tox.ini || die
+ sed -i -e 's:test_package_version:_&:' tests/test_core.py || die
+ distutils-r1_src_prepare
+}