summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 06:06:31 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:47 +0000
commit624c6ea066f2002e92fcf3097274c71458d6f54d (patch)
treecef177860a056ab890e5678c196a7a7ed633de05 /dev-python
parentdev-python/pyxattr: bump to 0.7.2 (diff)
downloadgentoo-624c6ea066f2002e92fcf3097274c71458d6f54d.tar.gz
gentoo-624c6ea066f2002e92fcf3097274c71458d6f54d.tar.bz2
gentoo-624c6ea066f2002e92fcf3097274c71458d6f54d.zip
dev-python/pyscard: bump to 2.0.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 979f7beaf580..24c2447ca82e 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-1.9.9.tar.gz 145428 BLAKE2B c62d9c2f13d9f19df1b7399509efc9df2baf2da00a9dc0bd9a0b440dcef232beeb0f7da88b12e3fb8ecffeb28f268eaaa04c9d45dc3420a1071835afe7a36c95 SHA512 88c7314c10153f509eb9bf6318e62210c7182e51b531af752a402bf8d05cfa2658cc1a4e7b9385a474038ddfa5a1bfbf1f208fcd9abe02a60161ce7c757c67b2
+DIST pyscard-2.0.0.tar.gz 148326 BLAKE2B ea9e3fbe404dedd7e7290743da4dfe51196beaa7db7ce69ad47316c70afe044cbf3e32666d32786e0d68f225cc6d552b7bb5c79fc62132c6fbee502868d3a205 SHA512 cf2cda96cdbc8f1abc20f969355a9c07698c7c13d826482170f7114962cc683b3c9b8a39aa19b76b6ae1e6c6e8875407bb9fa04908a0b22c96d0b3cbd234fe0b
diff --git a/dev-python/pyscard/pyscard-2.0.0.ebuild b/dev-python/pyscard/pyscard-2.0.0.ebuild
new file mode 100644
index 000000000000..2c0b3a74b911
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}