summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-17 10:57:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-17 11:13:02 +0100
commit64b437832a0a17330389789b2ae33a519fe46354 (patch)
tree568f7a1787aef7c5f2335c6878498562c258c64f /dev-python
parentkde5.eclass: Add _kde5_really_dead eqawarn in pkg_setup, pkg_postinst (diff)
downloadgentoo-64b437832a0a17330389789b2ae33a519fe46354.tar.gz
gentoo-64b437832a0a17330389789b2ae33a519fe46354.tar.bz2
gentoo-64b437832a0a17330389789b2ae33a519fe46354.zip
dev-python/falcon: Drop py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/falcon/falcon-1.3.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/falcon/falcon-1.3.0.ebuild b/dev-python/falcon/falcon-1.3.0.ebuild
index 33bc228d74a2..9806360ed00c 100644
--- a/dev-python/falcon/falcon-1.3.0.ebuild
+++ b/dev-python/falcon/falcon-1.3.0.ebuild
@@ -6,7 +6,7 @@ EAPI=5
# Python 2.6 is supported, but depends on ordereddict, which has been in
# improvise for months and is a minimal package. If needed
# please let me know. PyPy also works
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
@@ -22,12 +22,12 @@ RESTRICT="!test? ( test )"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]
dev-python/mimeparse[${PYTHON_USEDEP}]
- cython? ( dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
+ cython? ( dev-python/cython[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
+ dev-python/cython[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]