summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 06:31:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 06:56:59 +0200
commit66b707cced093c64282b61ec76e92ce80aeaf893 (patch)
tree2d09b368bb9f4decb009310e8e09dcb21595b4a0 /dev-python
parentdev-python/awscli: Bump to 1.19.79 (diff)
downloadgentoo-66b707cced093c64282b61ec76e92ce80aeaf893.tar.gz
gentoo-66b707cced093c64282b61ec76e92ce80aeaf893.tar.bz2
gentoo-66b707cced093c64282b61ec76e92ce80aeaf893.zip
dev-python/dulwich: Bump to 0.20.23 (NFC)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.20.23.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 6cbb2f0775bc..e2babb26eb15 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,4 @@
DIST dulwich-0.20.20.tar.gz 397197 BLAKE2B 941cb09c0537ec9ab96fc65cac12f94cc74b549eb2a8a516def96f66a8d31ad602ae4253910a24efe7254411dd4723832481b0df3189a9cb8708e3bbd512eb6f SHA512 ca83bfe3566981830bdc91d2e4ed039625fa6780dcabf74e0e91c9d89001e06dd04c8a10e8dfaf5c5ad67081d77fc9e996e2e3e1a0589954faae09162c545b02
DIST dulwich-0.20.21.tar.gz 399232 BLAKE2B d2768a4cc83ab2dad3b569c7c97c93ffea0293eb10ce269a7edfc7d5a6dc15d31d7637332d6968d40e67dcd2d76d6f9366f6d2e30527a666bc76fab32c5bab91 SHA512 1dc3042ef7ed0320b8e998d78c98e5d181981f665a708547b715ed5a16869f5c0c76b6228bf1e58cb957923ea9643ae2ae7cfca970056bc5230db18c5a110985
DIST dulwich-0.20.22.tar.gz 414104 BLAKE2B 6fcb2ef8b7498f0fbf934440ab269a4c63e1722ec9ed4b2ade549e88377c33dbc6fcdff433acb7187bfaf3eebfb7698f7e9688088440f70be448dd7e112cbffd SHA512 ccb7330f9ba0bda5ceac31a62cb4a251cd95e70205535f033678553d17cfb720139135364b60747d24d682a1decd447d69c5180150af25fa05d68a7bdd21e7c5
+DIST dulwich-0.20.23.tar.gz 414150 BLAKE2B 0f7bfb237acc6bad874465a5bfed21adc29a2ef23875fbcbb92e7e3ff0ed6a4191a30b3975f90ef20b8320575e42abf31f8ec2199d558382c917d0510c2a8d96 SHA512 8bad3528dc87e70b39b59b2f7218579327db4dbd15937b63db76c9b8e7ba6d22e963eaec45b8d675c92f250516a541c395fdac391db68d0932dc5d8cd7ed9fb9
diff --git a/dev-python/dulwich/dulwich-0.20.23.ebuild b/dev-python/dulwich/dulwich-0.20.23.ebuild
new file mode 100644
index 000000000000..c3784feb382a
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.23.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/dulwich/dulwich/
+ https://pypi.org/project/dulwich/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) )
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}