summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-28 01:21:41 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-28 01:26:09 -0700
commit66c1cbb0a799c7263a6da4f757cc3240cb9a2fb9 (patch)
tree46e518cdcde327e006fc0e876e647541af823d58 /dev-python
parentdev-python/semver: new package (diff)
downloadgentoo-66c1cbb0a799c7263a6da4f757cc3240cb9a2fb9.tar.gz
gentoo-66c1cbb0a799c7263a6da4f757cc3240cb9a2fb9.tar.bz2
gentoo-66c1cbb0a799c7263a6da4f757cc3240cb9a2fb9.zip
dev-python/requests_pkcs12: new package
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests_pkcs12/Manifest1
-rw-r--r--dev-python/requests_pkcs12/metadata.xml15
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/Manifest b/dev-python/requests_pkcs12/Manifest
new file mode 100644
index 000000000000..0595f75eac2d
--- /dev/null
+++ b/dev-python/requests_pkcs12/Manifest
@@ -0,0 +1 @@
+DIST requests_pkcs12-1.4.tar.gz 3884 BLAKE2B ebeb89349163d4f9995c00dfe3d725036a76660870d36203f47029f225698fe7a15993a9dd756e0b6b33011726ad26323962609bb94f223f4478096658f20a3c SHA512 f77703b7b0ba1f13aa095fcf4955f119c34a20e0601e0d6888a29932d8d4289548cf2b7b0e065abfea2ebcda542d48a4d9a3ded32974c1d24bdae223893f0241
diff --git a/dev-python/requests_pkcs12/metadata.xml b/dev-python/requests_pkcs12/metadata.xml
new file mode 100644
index 000000000000..0a878536db01
--- /dev/null
+++ b/dev-python/requests_pkcs12/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Adds PKCS#12 support to the Python requests library in a clean way, without monkey patching or temporary files.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">m-click/requests_pkcs12</remote-id>
+ <remote-id type="pypi">requests-pkcs12</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild
new file mode 100644
index 000000000000..717b7c6e3fa5
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"