summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-07-01 00:13:12 -0400
committerTim Harder <radhermit@gentoo.org>2018-07-01 00:16:16 -0400
commit67bfe402d69b26ec8be80db463f52b331ca659af (patch)
treea203f4fcc291bb4d16980bf48be0606343a7d2c6 /dev-python
parentdev-python/greenlet: version bump to 0.4.13 (diff)
downloadgentoo-67bfe402d69b26ec8be80db463f52b331ca659af.tar.gz
gentoo-67bfe402d69b26ec8be80db463f52b331ca659af.tar.bz2
gentoo-67bfe402d69b26ec8be80db463f52b331ca659af.zip
dev-python/llfuse: version bump to 1.3.4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.3.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 1ea4c1435f24..44ecfcf2deb6 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.3.2.tar.bz2 348035 BLAKE2B d3a3219c8d7462f448486488971842362b6ade8fcf6804d725db30b0e91d3f240ec9443705cb67caf3e6beae8a174f323465695dddd132210e3606aef6dd861d SHA512 f065818134b12dd128574836bc7d339404d9b7d9236b535da709378e9206b17cb2accd97fc0b658f39a93efe126a7c3064f7901468231f63f8398a3e053498cf
+DIST llfuse-1.3.4.tar.bz2 364400 BLAKE2B 726a42381b84fc57e3e54d519bc1a105056cc8cf5d1c586ea12b1798db493254df7088f1060ffda0d89887c2b7db2046825e4f044953153e7978891f72032457 SHA512 6bda4534f660c42e6740093be0a2c308367f5915a0144d44c390b4f6b197efafb48bc28f7f8d1735defe470e37637bd6688690e26ec3d0c01cb7c197e443f6e6
diff --git a/dev-python/llfuse/llfuse-1.3.4.ebuild b/dev-python/llfuse/llfuse-1.3.4.ebuild
new file mode 100644
index 000000000000..106a17eff394
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.3.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0:0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7 pypy)
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/attr
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.3-cflags.patch )
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}