summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-10 22:26:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-11 01:13:09 +0200
commit68efbcafd90fee51027ad9a1812d9717af6734a1 (patch)
treeb4350fd9fd960ccd7933a5fe57926a856f7410d2 /dev-python
parentdev-python/terminado: Bump to 0.10.1 (diff)
downloadgentoo-68efbcafd90fee51027ad9a1812d9717af6734a1.tar.gz
gentoo-68efbcafd90fee51027ad9a1812d9717af6734a1.tar.bz2
gentoo-68efbcafd90fee51027ad9a1812d9717af6734a1.zip
dev-python/botocore: Bump to 1.20.92
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.92.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a533df2715a6..d87bee99bb5c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -13,3 +13,4 @@ DIST botocore-1.20.88.tar.gz 7806185 BLAKE2B 21c3e3420fc9810712a462cfab4f43509eb
DIST botocore-1.20.89.tar.gz 7808318 BLAKE2B cc160b85d7e85267aa4bd7140c8f90b33dc07e5b8c0cf2cd4761ea456dfa955bd95b500e8da89bd9cca70237edcbd7df45c8f1d543e4e67646a8e597a5516fb5 SHA512 41fd7cf61b8eddb3e467d6d6b115c53e75413bdd3bb181723dd48c6efdd7133eee45ac597bf207482b2aa5872bf79d7801176194e474c61614599119df67db5a
DIST botocore-1.20.90.tar.gz 7810567 BLAKE2B f34ce1e4ed16254585a90e3ba1674a35909169a0a73a216e0b5d60609567133ce1257fc3b48a21e3c707b42db546612f40263e20fb68eba1e01cc3560ed5ef15 SHA512 4765abfe9913bb214d1c4aeacc00f5b5745322121bbb1e652705fbd63a9801476e513596078f833306834047f42b39edc9de31939f02860476fdb825f4b654b1
DIST botocore-1.20.91.tar.gz 7822478 BLAKE2B d76b3a944f951a9722e59d28218e24eacbcc9282235df6adbbf9ac01b12dc96e446a7dbec06ab08433513a3f1dd1f39ac8db85c4aa3cfcd99348fa57e85b2246 SHA512 730b664b050db5df7c9f9f3ab89e7c7f541b0c921a0a6f38f4d0d7a4594f89b61929d5251799c2cf08bda1107567c636d036379b328db788178ae7af18157366
+DIST botocore-1.20.92.tar.gz 7826845 BLAKE2B 8568b8be7440807fae48f735198059356764c7f36db1dfcf73801379ea90b728bb02a086e19a202bb5b3a7c05886edbc22ca729a1ea43ac1f38ad96b64a6c28b SHA512 0cba710b28086b4e83c6269e74ca3531b26497d438e28b8ea285f7fbee0da43545134d22fe5fb300d3c77d9c933882b1f00cde797c470e6af73553c191cebd66
diff --git a/dev-python/botocore/botocore-1.20.92.ebuild b/dev-python/botocore/botocore-1.20.92.ebuild
new file mode 100644
index 000000000000..762144aabf71
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.92.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}