summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-27 09:39:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-27 09:47:59 +0300
commit69dac2a123caaa276010346e769481c8fc32ca6c (patch)
tree692b194a0c605e9ce77f0005229b76f1cf189163 /dev-python
parentdev-python/django-auth-ldap: enable py3.10 (diff)
downloadgentoo-69dac2a123caaa276010346e769481c8fc32ca6c.tar.gz
gentoo-69dac2a123caaa276010346e769481c8fc32ca6c.tar.bz2
gentoo-69dac2a123caaa276010346e769481c8fc32ca6c.zip
dev-python/cx_Freeze: add 6.8.2, enable tests, enable py3.10
Bug: https://bugs.gentoo.org/765385 Closes: https://bugs.gentoo.org/812341 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cx_Freeze/Manifest1
-rw-r--r--dev-python/cx_Freeze/cx_Freeze-6.8.2.ebuild46
-rw-r--r--dev-python/cx_Freeze/files/cx_Freeze-6.8.2-buildsystem.patch13
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/cx_Freeze/Manifest b/dev-python/cx_Freeze/Manifest
index ece5807e2b88..39f3a7b87753 100644
--- a/dev-python/cx_Freeze/Manifest
+++ b/dev-python/cx_Freeze/Manifest
@@ -1 +1,2 @@
DIST cx_Freeze-6.6.tar.gz 120239 BLAKE2B f4ba5de3f4233ee5417d1e1dfb8ad23180d59bf7b2b2da4918c390d69e6f73cb814a1063951b2564bd4f8eabe8aff5faf9f731fe500bf90b4a5ef8cd081632a4 SHA512 24305f19c10d13ea58d995d80dc43c884898ae1e29a470d2885b6d7448806103bc7771874cc6dd064114c6e5e59f351dfec71c37ef3dddc0a136bb5a166cdb3a
+DIST cx_Freeze-6.8.2.gh.tar.gz 1271879 BLAKE2B 5c0feb7fdb51edd9e1c3a508d3d2401d1930986ee8caf957ad84a853baed56b0a6d9bd09628331adac67b4b8c79059c5a6669f8a52f22596cd1d42c87ae8d7f4 SHA512 7c7de3290597ab986326ee67b9cb8fc3dd554cef2940e3df11df5be23a6a5b4eebb33784149aff59ebec97663c8a2e70b0811cb7c244cabe43659c59882ecd40
diff --git a/dev-python/cx_Freeze/cx_Freeze-6.8.2.ebuild b/dev-python/cx_Freeze/cx_Freeze-6.8.2.ebuild
new file mode 100644
index 000000000000..7dea19185598
--- /dev/null
+++ b/dev-python/cx_Freeze/cx_Freeze-6.8.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Create standalone executables from Python scripts"
+HOMEPAGE="https://cx-freeze.readthedocs.io/"
+SRC_URI="
+ https://github.com/marcelotduarte/cx_Freeze/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ virtual/libcrypt:=
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_8)
+"
+BDEPEND="
+ test? (
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # bug #491602
+ "${FILESDIR}/${PN}-6.8.2-buildsystem.patch"
+)
+
+distutils_enable_tests --install pytest
diff --git a/dev-python/cx_Freeze/files/cx_Freeze-6.8.2-buildsystem.patch b/dev-python/cx_Freeze/files/cx_Freeze-6.8.2-buildsystem.patch
new file mode 100644
index 000000000000..760ac42fb942
--- /dev/null
+++ b/dev-python/cx_Freeze/files/cx_Freeze-6.8.2-buildsystem.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 3149360..e06a1d3 100755
+--- a/setup.py
++++ b/setup.py
+@@ -99,8 +99,6 @@ class build_ext(setuptools.command.build_ext.build_ext):
+ # macOS on Github Actions
+ extra_args.append("-Wl,-export_dynamic")
+ else:
+- if not self.debug:
+- extra_args.append("-s")
+ extra_args.append("-Wl,-rpath,$ORIGIN/lib")
+ extra_args.append("-Wl,-rpath,$ORIGIN/../lib")
+ self.compiler.link_executable(