summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-11 19:34:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-12 10:46:49 +0200
commit6b879c610467c0ab51ec6551f331ab3b1af2fb3d (patch)
tree595404e2ba1491a1fa1be3e2331a6f8461f2972d /dev-python
parentapp-vim/vimbuddy: stable for all arches using the ALLARCHES policy. (diff)
downloadgentoo-6b879c610467c0ab51ec6551f331ab3b1af2fb3d.tar.gz
gentoo-6b879c610467c0ab51ec6551f331ab3b1af2fb3d.tar.bz2
gentoo-6b879c610467c0ab51ec6551f331ab3b1af2fb3d.zip
dev-python/brython: version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 2613fce606c5..ac079c34c667 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,2 +1,3 @@
DIST brython-3.5.0.tar.gz 9232597 BLAKE2B a01c01cf0e67589bd58312e05eb56b11b7905c19e2ac62b895d3352ff9aa0eba141a52437ab12a1aec43e63d07714b56822db2aa82bec89b46c2c9f8b0980c45 SHA512 a0ba2e66712fdf41d64fee4f832d1e620a965099cb506660268d43c9ff00c808d853ac7b7373bad9bfc16f3ec7b60066ed6ba28c33d7df151624169b272951cc
DIST brython-3.5.1.tar.gz 9238724 BLAKE2B 88237a237afd65a7a4b66e74fdb38d10adb30a41f86536baf0f66754fe9ba32b4fe96938c2856d8ccaf1edf846b90dda730e5d22dd7372108e8dc3c274926ce5 SHA512 90666cd1ecb82432099da0acbe47f6693aeddd9cb2db939ae98af43560589924d3aac0aef6ed3191ae496c76bbfc5d8a5916917d2ba4b38da422e4d8cffb6013
+DIST brython-3.6.0.tar.gz 9310837 BLAKE2B 616874f2a9c303e910a3fd2910aad6ffe360f87e98d009d66e85fd8c05d61c5d96c1a313214c08b69b5d073a23008b23d882a607af0d54f7d2942fcd2b6861ff SHA512 c59cee89634a2439a6fc64d3397966762aa508c6c00d05186138acce25fcf6597230511e30a261217898bca3d86a11eea92516cfe630c5d82cb271603dbecb2c
diff --git a/dev-python/brython/brython-3.6.0.ebuild b/dev-python/brython/brython-3.6.0.ebuild
new file mode 100644
index 000000000000..50f67db89823
--- /dev/null
+++ b/dev-python/brython/brython-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}