summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 05:58:34 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:45 +0000
commit6bb48740093e11108aa2a0d1718d718a68cbcc0a (patch)
tree740be6f70a876edd1550f92874f7de153d829805 /dev-python
parentdev-python/pkginfo: bump to 1.6.1 (diff)
downloadgentoo-6bb48740093e11108aa2a0d1718d718a68cbcc0a.tar.gz
gentoo-6bb48740093e11108aa2a0d1718d718a68cbcc0a.tar.bz2
gentoo-6bb48740093e11108aa2a0d1718d718a68cbcc0a.zip
dev-python/peewee: bump to 3.14.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.14.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 770386da5c0c..59cbae45c29b 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1 +1,2 @@
DIST peewee-3.13.2.tar.gz 871323 BLAKE2B 18fd9729ddd6ce3fe4a6963b697815d44e91b5078ba0b868e6b4f24f4cec9c5b01239d7f414f4f8c0871d3dc6bd5e0e37e218c9438cf1f7461bf729cb74049e4 SHA512 7304473f8e64df7cb2205900cfbdd52346d89e9639dc79ed6e13d5c4c11cc856e39e366772039097dc5ca86b4768fa4670dccd96a85cabfb522c463b31c40a8b
+DIST peewee-3.14.0.tar.gz 877299 BLAKE2B 25d0027354258c3b2a4db0765f8dac23527816c24afdaf20252e244cfec383a4ae4f10a29ea0f801d5c38406f8c17bcc6fef881b4bce96ed45920a8865868e80 SHA512 083bb24952a6d05cd6c8376e185e050df0ab5b37bc553241128b0ed3b0ebdd322d9626c32943658324d413cff8ab0bb2ddf6c84d99a0fbe057c0e5c8ec93d7f9
diff --git a/dev-python/peewee/peewee-3.14.0.ebuild b/dev-python/peewee/peewee-3.14.0.ebuild
new file mode 100644
index 000000000000..ef29b62487d2
--- /dev/null
+++ b/dev-python/peewee/peewee-3.14.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}