summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-18 12:33:14 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-18 12:46:47 +0200
commit6d888fd8c081295cc9e3806c10e77cbffc42dbae (patch)
tree42da4c3da98a27b759fe9ec4bd461e01fad0b108 /dev-python
parentdev-python/ansicolor: EAPI8, py3.11, PEP517 (diff)
downloadgentoo-6d888fd8c081295cc9e3806c10e77cbffc42dbae.tar.gz
gentoo-6d888fd8c081295cc9e3806c10e77cbffc42dbae.tar.bz2
gentoo-6d888fd8c081295cc9e3806c10e77cbffc42dbae.zip
dev-python/argh: update EAPI 7 -> 8
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/argh/argh-0.26.2-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/argh-0.26.2-r3.ebuild b/dev-python/argh/argh-0.26.2-r3.ebuild
new file mode 100644
index 000000000000..c5f41e33c34b
--- /dev/null
+++ b/dev-python/argh/argh-0.26.2-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="https://pythonhosted.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.9-msgs.patch"
+)
+
+distutils_enable_tests pytest