summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:46:30 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:47:20 +0200
commit6e3d68f51478dc05189e66746fd68d961635a69c (patch)
treef6aa1d9714460059f200b28174ab8d845d85f536 /dev-python
parentsys-apps/gsmartcontrol: Bump to version 0.9.0 (diff)
downloadgentoo-6e3d68f51478dc05189e66746fd68d961635a69c.tar.gz
gentoo-6e3d68f51478dc05189e66746fd68d961635a69c.tar.bz2
gentoo-6e3d68f51478dc05189e66746fd68d961635a69c.zip
dev-python/urllib3: Bump to version 1.21.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-1.21.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index c18a3d27003f..7486802a0f7f 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,4 @@
DIST urllib3-1.12.tar.gz 151072 SHA256 0ea512776971fe4e76192600fe41e4e7ee96b4b9a5b15aefc1ac31d2a63872c6 SHA512 44f1cf9c5d5538e35d026551a2d1dc7119786c1148b9a769fa9f652f0368e996512962c6245c92d1f4bb1d8e816e2fb0ffebeb0060b01f92b2a5d6e01d15426f WHIRLPOOL d386e4fb47b2ea4d78d2ad690c9252d6be1b3f5a624e20670e22c9b3a28dc910e3d5ecd24ca54d8f8337f8e9a9875208efce06952cd392d9c8254257eadeee70
DIST urllib3-1.16.tar.gz 179763 SHA256 63d479478ddfc83bbc11577dc16d47835c5179ac13e550118ca143b62c4bf9ab SHA512 646b35a9a4490b2d1f068883a29cbb5be5050a6eea7bb7842f77cd666b7f88101a7612e8eb45ae0eb900d914518db5202f548ab688b8db1c20ed248ba2edac66 WHIRLPOOL a4a813a5fc560a1487a87e492185122ffe8a41ba263e3c5e5962a48b9f4577a6360fa5d47d474f3c97a56e7ef99b2854c0f742075c05b88461f41d69e10c7a04
DIST urllib3-1.20.tar.gz 201873 SHA256 97ef2b6e2878d84c0126b9f4e608e37a951ca7848e4855a7f7f4437d5c34a72f SHA512 5e2c960ad8641b7e7faf3df966ceb5a2fbb898d9fb4d4459ba607448bab096e3d5df6bc42fdf5fbc2ea58fb6199ba3eb16613b63fd109401d6a2b6e46aade6c3 WHIRLPOOL 30938f71f77e300c9ccc050b6b1f071941db644b5c34ceba262fa839659a7d9655fe22bc867e63edde5dbae790a4505cbea370962cc495700d6b1c6b40c2b98a
+DIST urllib3-1.21.1.tar.gz 224266 SHA256 b14486978518ca0901a76ba973d7821047409d7f726f22156b24e83fd71382a5 SHA512 0d2e9c2a0b895e4e232cad5ecc645ea9fd9b70191df045a220ee1f32e284c613c6790bcdfd9e40a22ea9d25ec397278fa700a3c3747e7b04222719d50df07859 WHIRLPOOL 58df2abc5d211fa312e7a7967367c0bac9f029848a6fed15fb83d3b0b197e9834fa60f71d2ec2577dfc464c30d3e446035252fac830da500111976e77a4e904b
diff --git a/dev-python/urllib3/urllib3-1.21.1.ebuild b/dev-python/urllib3/urllib3-1.21.1.ebuild
new file mode 100644
index 000000000000..8dcad14a6c77
--- /dev/null
+++ b/dev-python/urllib3/urllib3-1.21.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
+HOMEPAGE="https://github.com/shazow/urllib3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=www-servers/tornado-4.2.1[$(python_gen_usedep 'python*')]
+ >=dev-python/mock-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.7[${PYTHON_USEDEP}]
+ >=dev-python/nose-exclude-0.4.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+# Testsuite written requiring mock to be installed under all Cpythons
+
+python_compile_all() {
+ use doc && emake -C docs SPHINXOPTS= html
+}
+
+python_test() {
+ # FIXME: get tornado ported
+ if [[ ${EPYTHON} == python* ]]; then
+ nosetests -v test || die "Testing failed with ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}