summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:43:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:53:29 +0200
commit6e8916f474709704d2b1ed08dbb070a34dbd45b8 (patch)
tree65d0398e2b1722fac44efcd3a37808d9f9344740 /dev-python
parentdev-python/munch: Remove redundant versions (diff)
downloadgentoo-6e8916f474709704d2b1ed08dbb070a34dbd45b8.tar.gz
gentoo-6e8916f474709704d2b1ed08dbb070a34dbd45b8.tar.bz2
gentoo-6e8916f474709704d2b1ed08dbb070a34dbd45b8.zip
dev-python/mysql-connector-python: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest1
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.19.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index 3b6c5e8b73af..f5a6ffea00f4 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,2 +1 @@
-DIST mysql-connector-python-8.0.19.tar.gz 12051609 BLAKE2B 252d4ee650c1eddbe54575451ac378236b6a795237c445239ecec096c7adcb60da2244592f083a50df57c9e2ae6447f1dcaf861042973a31c3fe7292509ef93d SHA512 9137b0b6aafbff16c83f59ab03da810232a92f6b76e38f460782153c5ddbdf6ae55d0c72a0c7902b7bc05ad1010bdc849662cd3d2138ae93476abf013e7a508f
DIST mysql-connector-python-8.0.20.tar.gz 12058227 BLAKE2B ac16d0eb7ccc884e89bd493ce821b06223c7ea7a4c4ffce2ebc586c736524d826d92d3e3c7803c1f937c93a9f28df32205a04b3bd80474650e90bc267661879d SHA512 3b7298036f1b28eed98ca05ebc52619dbdf65393b4a01bf6eccea87d298da430ecfd19a3b327050ebc48b2c237698c7545c0196949d84cb79117f4d767d736aa
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.19.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.19.ebuild
deleted file mode 100644
index b6c5eebd14bc..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-8.0.19.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-BDEPEND=">=dev-libs/protobuf-3.6.1"
-
-RDEPEND="
- >=dev-db/mysql-connector-c-8.0
- >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
-"
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt README.rst )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
-}
-
-# Yeah, this is really broken, but the extension will only build this way during "install"
-python_install() {
- distutils-r1_python_install \
- --with-mysql-capi="${EPREFIX}/usr" \
- --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
- --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --with-protoc="${EPREFIX}/usr/bin/protoc"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}