summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-08 22:15:03 +0300
committerMichał Górny <mgorny@gentoo.org>2023-08-08 22:06:47 +0200
commit70745f272624c8c0c23ed377d38cd5c0f23d7190 (patch)
tree15d3d80c76cdccacf4e15098006fb8e2f5ae0f0b /dev-python
parentdev-cpp/gtkmm: Version bump to 4.12.0 (diff)
downloadgentoo-70745f272624c8c0c23ed377d38cd5c0f23d7190.tar.gz
gentoo-70745f272624c8c0c23ed377d38cd5c0f23d7190.tar.bz2
gentoo-70745f272624c8c0c23ed377d38cd5c0f23d7190.zip
dev-python/sqlglot: add 17.10.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.10.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 07b553a4041b..9354f6da6ab9 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,2 +1,3 @@
DIST sqlglot-17.10.0.tar.gz 8390551 BLAKE2B 634b771dfb028feec56e643a1806801d7adaa8fb35c18e13241cf278e11da37cf5cb121f1b470b893da5d4bcb2972bfe8c271ff071a99ae2a2887568afe7b464 SHA512 1fb9dc5981e0dd57814ba1f86109a382359dedfad0dee8da241e126ae2e3365372afa3de76c4a1be60fa8993883ab643322812d71e68986bca8a97ecb5a35edd
+DIST sqlglot-17.10.1.tar.gz 8394322 BLAKE2B e7d922644e3071ccc6ce666b10081ce24095cbed6d2136c70e632d241196058762167874b175e6b000dda91922d72000fd6f57d8ae775dec588915f10a51d2e8 SHA512 6cbf3c82e5fee73dcbfe677213c10325a5fb81c8f93ba594d88abe9fb7d3a6580c6c6adebc6551cbe1dc8ae51ad68ac33a0242088e68dd80ef3e7285f4479ad1
DIST sqlglot-17.9.1.tar.gz 8389281 BLAKE2B 97c1642a42940344cffb9a6c53db44d4850d0d4b029dde16f202288515d40cfb3a405813893140041bd19c30ed9dfa9d1ab104e0a61a6ccefa140df26fa86eb9 SHA512 925b56cf0bb84a58416b32af33ed37c30ca93d56244ab3cd6f72276dbeb448a85e3b1919c9bca77f3d0c51b9de70f0b98afc666067b1377ede8e52dea3d71267
diff --git a/dev-python/sqlglot/sqlglot-17.10.1.ebuild b/dev-python/sqlglot/sqlglot-17.10.1.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.10.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}