summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-09 08:36:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-09 08:40:46 +0200
commit709d288c8f093228ccf1e8c2b6d24c15d6845361 (patch)
tree239f97fd5b5015988f954b4d4648f96946be059f /dev-python
parentdev-python/agate-excel: Bump to 0.2.5 (diff)
downloadgentoo-709d288c8f093228ccf1e8c2b6d24c15d6845361.tar.gz
gentoo-709d288c8f093228ccf1e8c2b6d24c15d6845361.tar.bz2
gentoo-709d288c8f093228ccf1e8c2b6d24c15d6845361.zip
dev-python/xdoctest: Bump to 0.15.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index df51feee3b3f..d791719d1906 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-0.15.4.gh.tar.gz 179295 BLAKE2B 0b44276a219119196543671d8ac24469ecd73b040bbd03ca416320d407f0dd34361dbb2778121621f6efb65835ea421107883277b6e712f03e4c06ea2b03dd6a SHA512 a0a35d5c73a8696266d9be44d11e9dbf05c9ac1165a05e681f7b70ef07ae7d56f4bd179e863b6675e2366f1627015e92092e8250ca592f004680db5ad886ad49
+DIST xdoctest-0.15.6.gh.tar.gz 182717 BLAKE2B 39af1bdc381e6b6044321ca1dae8ae893d4af9ba8d595ce5dad0fea7e805420635bc9f9a2c04726cb03a7fa0311eb1df1f93aa59e682790e15a3e119356d7b9a SHA512 5c7a7cfea9a7b37e8e5a383b59896730420dbf737a4217bd19ebe083b48a6d410b0e6713b0e5b9749527ff3992f3d24b83d49622bcde0a68722ecab8337d7040
diff --git a/dev-python/xdoctest/xdoctest-0.15.6.ebuild b/dev-python/xdoctest/xdoctest-0.15.6.ebuild
new file mode 100644
index 000000000000..3f8b3416a702
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-0.15.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest/"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme