summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-13 19:33:01 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-13 19:33:25 +0100
commit71504b9e8d37a257e9b922e33f051b96eeffa8ed (patch)
tree1409c9739ed3123f48d409d0e4efac4933b5575a /dev-python
parentdev-python/docker-py: 4.1.0 + EAPI 7 (diff)
downloadgentoo-71504b9e8d37a257e9b922e33f051b96eeffa8ed.tar.gz
gentoo-71504b9e8d37a257e9b922e33f051b96eeffa8ed.tar.bz2
gentoo-71504b9e8d37a257e9b922e33f051b96eeffa8ed.zip
dev-python/colorama: 0.4.3
Also drop dev-python/setuptools from BDEPEND as distutils-r1 already adds it for us. Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/colorama/Manifest1
-rw-r--r--dev-python/colorama/colorama-0.4.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
index 3fa8ede57880..13ac7224a67b 100644
--- a/dev-python/colorama/Manifest
+++ b/dev-python/colorama/Manifest
@@ -3,3 +3,4 @@ DIST colorama-0.3.9.github.tar.gz 122180 BLAKE2B 0ef1b2876a8d790e434548649d34bc3
DIST colorama-0.3.9.tar.gz 25053 BLAKE2B f633a188d032c41d0b6de60540ca1774dd8f3e8fe2e558333baf09855db30fa7a7ade5944ff12e4ca1a3685930d10a02009162733666d711ad25a16ee96ace55 SHA512 248e3d3d1f95cb85baf55ef4d705508213b81edfb04b39fe9a7bc9c7ac564986726ab6e9d9f73d64ee02e1c9b86d4c6bba40543590dbd170180a37d69e07b627
DIST colorama-0.4.0.github.tar.gz 104679 BLAKE2B 416a8bc5af470dc22b71a84279e4d984b57fad7ddb617c80c9104830127efa4f545eb08c003d263e48edbc0db39bc150e74f64f68f22075e759c11a6e84c75d5 SHA512 e2214c0a4ce1dd5515cf12cbb91220d2314da747b1a1246641117e70ea81b162cb4748b2b5dff049e102540470617a0076a3afff64bfe67158bf7bd95e1cc6f8
DIST colorama-0.4.1.github.tar.gz 104708 BLAKE2B 625c6ff325ff0de8113c5c9abe9dd296eb614b0483a2dce59b163431ec4ef1992073719160143b68e76d3ad77f77b975a110ce19496be1d8f6ee90b3f66b6e7b SHA512 006069859ca05ec8a6808860ca73ab541b246e6e6443b1bc8426973beaa5268660b48994f21edb6492fe97c4b9d29949b874b861ec200b1756d40e8abda8dee0
+DIST colorama-0.4.3.github.tar.gz 107251 BLAKE2B e09e92171b6ea4b3db4801feaf794e9aeb4f2b3e57079907911cbb909167b192eb857f0b404fa45673bee3bc02c122326bd05091846755d7dbfd990a74c60a24 SHA512 ab41a2f95fe75de0b280c174c6166b86645e5cc675dcedf784fe15170aae630e831370527c9490342b77c7d088a023a48428a519b52ad1c70be58904742a94c8
diff --git a/dev-python/colorama/colorama-0.4.3.ebuild b/dev-python/colorama/colorama-0.4.3.ebuild
new file mode 100644
index 000000000000..ebf9d38ce484
--- /dev/null
+++ b/dev-python/colorama/colorama-0.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama
+"
+# https://github.com/tartley/colorama/pull/183
+SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ # Some tests require stdout to be a TTY
+ # https://github.com/tartley/colorama/issues/169
+ script -eqc "pytest -vv -s" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}