summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 11:31:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 11:36:06 +0100
commit715e71788ebb9cadc551a21518f7037a14039d9e (patch)
treee802beaf0b90303f8dd560b72417294d68fbfc59 /dev-python
parentpackage.mask: mask experimental postfix-3.8 releases (diff)
downloadgentoo-715e71788ebb9cadc551a21518f7037a14039d9e.tar.gz
gentoo-715e71788ebb9cadc551a21518f7037a14039d9e.tar.bz2
gentoo-715e71788ebb9cadc551a21518f7037a14039d9e.zip
dev-python/installer: Bump snapshot to 0.4.0_p20220124
Bump the snapshot to include +x fixes. While at it, switch to takluyver's fork with CLI support instead of applying it as a patch. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/installer/Manifest1
-rw-r--r--dev-python/installer/installer-0.4.0_p20220124.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
index def27fbb1e8f..b18a2088dca8 100644
--- a/dev-python/installer/Manifest
+++ b/dev-python/installer/Manifest
@@ -1,3 +1,4 @@
DIST installer-0.4.0-py2.py3-none-any.whl.zip 451433 BLAKE2B 933b7e63b3d0306213789d493d4df112df26b432d63ecd1f8f21449520c34bd2ad542aac25069043fbb535c44f988dca927625eafd0a5a20489fc3ce2bcf84a2 SHA512 cf303bb422e329a36007b361034144a232ba021d4013bb8678dc7c326544e74ec9a3b3fe8b9d3696433dbbe90d2ce4a0ae8967fb054bd5ed49321d470be729a8
DIST installer-0.4.0_p20220115-cli.patch 14552 BLAKE2B 6632c1472ae0a578f6c7ed0acf1bb0d89ece924626b68c0daa28d9a7d93826837adaf6b0d40f048c4f5c2986b4328ca565340137e7b7fa7f407f62ebddc70275 SHA512 f8c6369955e0bde2bff0b935c39748d02659bc6ca0341af405e2c1026cf145479ba0b908bd769cdc05f3cc920f881b894b6a5eb7ace643951e05250ec0486b80
DIST installer-0.4.0_p20220115.gh.tar.gz 466532 BLAKE2B 6dea3f4bacb52c4983e111d420495ee157076342a823b7062c6e5b3e4d3b70e6b2e9cb024d0c7baba6f88ed70f4303ab071d1882bc9d8dd0726f82a3e406056f SHA512 fbb0d4c8642fa2cbe2fd3be2eef7044a0353f04c67ecce20aafed33a0d7877ff55872ca5ad51390ae7e02cdb7af5dbd57b662085b60d425be95da6643b061eaa
+DIST installer-0.4.0_p20220124.gh.tar.gz 468296 BLAKE2B 44763fd05b9e3cc665871817f3a6a417ddc12274ae42989e96ad432af98d42c23ab9f1c1cc37e17d4b9ce06ead7ef0c8227b2b10fe5744c899a9e3ea347e4e33 SHA512 b25fa910e8a7d9a2757af4694bf12a64c8731213a5682ab02bbe472229c99dd9190b1e7663a7632d61cbf0585006b2d4de62115c40f9b132be2c70672e23726d
diff --git a/dev-python/installer/installer-0.4.0_p20220124.ebuild b/dev-python/installer/installer-0.4.0_p20220124.ebuild
new file mode 100644
index 000000000000..0dd705d57a43
--- /dev/null
+++ b/dev-python/installer/installer-0.4.0_p20220124.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+EGIT_COMMIT="05855a926b2e6d9a1be6d567300883b7a6ff3ce7"
+DESCRIPTION="A library for installing Python wheels"
+HOMEPAGE="
+ https://pypi.org/project/installer/
+ https://github.com/pradyunsg/installer/
+ https://installer.readthedocs.io/en/latest/
+"
+# TODO: switch back to pradyunsg/ upstream when the CLI PR is merged
+# https://github.com/pradyunsg/installer/pull/94
+SRC_URI="
+ https://github.com/takluyver/installer/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P%_p*}-py2.py3-none-any.whl
+ -> ${P%_p*}-py2.py3-none-any.whl.zip
+"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# NB: newer git doesn't use mock anymore
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_test() {
+ local -x PYTHONPATH=src
+ epytest
+}
+
+python_install() {
+ python_domodule src/installer "${WORKDIR}"/*.dist-info
+}