summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-04 10:35:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-04 10:45:46 +0100
commit7302be580f48a577b12f7462c0a37fa39f633376 (patch)
treee791e00f7eca12b9fee42b78f8758b6e1b324705 /dev-python
parentdev-python/matplotlib: Remove -flto (diff)
downloadgentoo-7302be580f48a577b12f7462c0a37fa39f633376.tar.gz
gentoo-7302be580f48a577b12f7462c0a37fa39f633376.tar.bz2
gentoo-7302be580f48a577b12f7462c0a37fa39f633376.zip
dev-python/hypothesis: Bump to 5.46.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.46.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 3536d13a1b89..5f896b9428ed 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-5.43.3.tar.gz 9103991 BLAKE2B e374edf17571c33e48dc8d259db
DIST hypothesis-python-5.43.4.tar.gz 9104105 BLAKE2B 08b8c9ac7ac72afcc4556ae2167af7b4ab79d505da8c9f6a11c91d211f26ccf320c8f5ed41458f5e34f75614ad4aecdbf6df62275868dc079c037390dcbc9e08 SHA512 065e1bdd878eab35f38105e8da3f5cf108670a51fd48ea1996bebedf8c8a152386d0eb5284ed43d4e588695a408b3a455a2e4757430e31bb5dbf0ece1f64d294
DIST hypothesis-python-5.43.8.tar.gz 9106677 BLAKE2B dd4334eb96e25cb31a16f06d1f7714bbf3631a7f09ed1bc46b9ce0d951b0718ac3ba0353ea4f71c221273f9c204380ab052e1bf4e3726e438a46585f6057b0db SHA512 475e6a60dd1132bcf1f4aed5e4cf6d478529e158583d4e81a1a74891037ff3fd80547a7adf5ee7263654984738fd983ef19fe8a6fb44cbd38160371ec30a6842
DIST hypothesis-python-5.43.9.tar.gz 9094672 BLAKE2B d7e6ca30556635d358b44e4bfaeb653d1960321d7c520907d6f3872e09eab0bb1a79dc70d0583e4642c16805150badb47f18ecdcff6c9991fb2a02a87453bc87 SHA512 1040dd8065604c175c5c138846c050ea1c28c5823e9ba17ffee67edfbae9a3ea071d9db40c844735513d2c7f1168aa6fef8d3fc3a3774cc49b6889b77816008b
+DIST hypothesis-python-5.46.0.tar.gz 9099456 BLAKE2B dd90cff66fd487427e1741eb7e31d7d04ed6e1070a3963dc55e607af0627f54d73b632a59620920565d1d1e900f97e44b6bc5d6cd0861d56a19a178f1b063878 SHA512 976575c27642f80fe903345d1b58eba5c984b78505da5c8ae4574b40795adc39e8fd8619b8fa887c796f62b772d958d1544efc883407c8500f882b9c6e9adf01
diff --git a/dev-python/hypothesis/hypothesis-5.46.0.ebuild b/dev-python/hypothesis/hypothesis-5.46.0.ebuild
new file mode 100644
index 000000000000..b910c24f12a5
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.46.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ <dev-python/pytest-6.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}