summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-12-05 18:54:50 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-12-05 19:10:07 +0100
commit758865665029068329c289b62e92716883f600ba (patch)
tree8016ee13206ad255979acd5863a3ff750f0b3f31 /dev-python
parentmedia-sound/soundconverter: Support python 3.8 (diff)
downloadgentoo-758865665029068329c289b62e92716883f600ba.tar.gz
gentoo-758865665029068329c289b62e92716883f600ba.tar.bz2
gentoo-758865665029068329c289b62e92716883f600ba.zip
dev-python/geventhttpclient: bump to 1.4.5
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.4.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index fc79f7d24ceb..f79e41f622b7 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1 +1,2 @@
DIST geventhttpclient-1.4.4.tar.gz 57620 BLAKE2B 20b60cfa7e8221b050bfd95a6e23c2f3eee87c0df1e93171719c7ba1804e88c918471cdd01cf4c6020fb6d44d0a1b911ee09dd44cc1e150b5d18d6052f2904cf SHA512 c6a8580707f3178a3a55eb638b9e3f36f82aecbd8a5ce044f0b8c167d88ad2bec584275bed6b720a5f7a546b0ffd113bec28dd2e1ff4290c60f0b5e13542b737
+DIST geventhttpclient-1.4.5.tar.gz 58183 BLAKE2B 48d44048e7040552824ed19ac49c6dda41536ffded56bae0d942c06f111a327a1d571872f35f388853b479ea1aaa6de518f86e7ee72e362360492530ade65131 SHA512 9ffe00c79b145dab104e1dce336e072060f315d9bee880daf64b5f1f52e661d810dab9a60286320a7d30cf0e794465f201c039cc31fe7ec325cdb3a8350c9f7d
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.4.5.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.4.5.ebuild
new file mode 100644
index 000000000000..7fb40b48518c
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-1.4.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ # Append to sys.path to avoid ImportError
+ # https://bugs.gentoo.org/667758
+ # Skip tests which require internet access
+ pytest --import-mode=append -vv ${skipped_tests[@]/#/--deselect } \
+ -m "not online" || die "Tests failed with ${EPYTHON}"
+}