summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 22:51:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 23:22:47 +0200
commit75a07238fbaa15392064c5060ddd275076e6db0d (patch)
treeec77bc5d40aa14fe47b4b92ce30a1fe2eb8ac827 /dev-python
parentdev-python/jsondiff: Bump to 1.3.0 (diff)
downloadgentoo-75a07238fbaa15392064c5060ddd275076e6db0d.tar.gz
gentoo-75a07238fbaa15392064c5060ddd275076e6db0d.tar.bz2
gentoo-75a07238fbaa15392064c5060ddd275076e6db0d.zip
dev-python/botocore: Bump to 1.20.54
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.54.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 58414758c4bc..72f87d1e0fd7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.20.50.tar.gz 7632505 BLAKE2B e52668e217d7dd9769df9cd8e45ee6b50db
DIST botocore-1.20.51.tar.gz 7636119 BLAKE2B 3c2892b1bdd7697232a3426874178b248aa7d026cd3559f46e5dc2e552cc5f9c7fc2a37575e69f31674e26eeaf2eae6015c8fc60e4b735e9c421dc2d47aa117b SHA512 98a816632f618df85b8d4fe5b1871856e9b77e4b3c627fd189fb36e8170380fa7e2304178a5e3bfcea206e9a6829bc0eab2455e16e7f21fd7271a7491fc8faf0
DIST botocore-1.20.52.tar.gz 7649448 BLAKE2B 3b27f838ca985df19ab97200c57eea65e43202170aacec270974cd29c8b7f6ea4cab9ad9d53332059aba0d1736fcbb3dd5048b076d8d23ef71f542f734325fc2 SHA512 68a0a66ef0fb732b66ce81043b87dff9174a83edcb2bdfa4779bed05c76738e51f9934f29873cb7d8daf111750e7e5fc12229eb9838c96d3fc8e58b3290b2ca6
DIST botocore-1.20.53.tar.gz 7650473 BLAKE2B 797280da052c547c10dc7c391b4d070624bd52ae8372f46e29b863ef5abf02f167d459f1013e2b46e3bb6878203f6dc7dabbad141fc89a52a46a770ec45a0cfb SHA512 ad7bc9fd06b24c8f15826ed19d6c5163d048206724c91dc82df58bb9d1bdcddaafd116543fe667df356fd5c098a975621f2e649df5937f97f54ddc9c15867252
+DIST botocore-1.20.54.tar.gz 7650344 BLAKE2B 2dd0a3f8c7c5665e849cf74b663a88e63416f1dea8ca3ee7dbdf10cf35239d466919f2ae4b3c9a639b9e25a23d982b723b24f32ece43715d40283e96e3bf10f6 SHA512 77cdaf68378836205c94c7dfd8424f9ca44ac822fd418d323df30639157bb38e5534fcfbc5bb6cdd7695bec62e24a1d52b81a0be54b0f69f16d20c5182db004b
diff --git a/dev-python/botocore/botocore-1.20.54.ebuild b/dev-python/botocore/botocore-1.20.54.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.54.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}