summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-23 16:22:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:41 +0100
commit760b5fdb397461dfa27c1d1ffdae7046abe38b80 (patch)
tree2514060c41fc00ae8411385cdcf3343e83324c41 /dev-python
parentdev-python/pytest-flake8: Enable pytest-flake8 plugin explicitly (diff)
downloadgentoo-760b5fdb397461dfa27c1d1ffdae7046abe38b80.tar.gz
gentoo-760b5fdb397461dfa27c1d1ffdae7046abe38b80.tar.bz2
gentoo-760b5fdb397461dfa27c1d1ffdae7046abe38b80.zip
dev-python/pytest-flakes: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-flakes/Manifest1
-rw-r--r--dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch17
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild25
3 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pytest-flakes/Manifest b/dev-python/pytest-flakes/Manifest
index 38db5f1fb820..545b526b2ef0 100644
--- a/dev-python/pytest-flakes/Manifest
+++ b/dev-python/pytest-flakes/Manifest
@@ -1,2 +1 @@
-DIST pytest-flakes-4.0.3.tar.gz 7312 BLAKE2B cf62d7e11a0521592325492c76e67cd51384b31d8a6191f10940230014c9a8797b3603e24664c022add5cec18ff7c3b558cd7507af47e8c90a9e90499f39e583 SHA512 ca63d68063cf48789d86dee3707b3ea7c5076fc1f636e17f408ad6f444303fb3a701af8d1e464d49af745e350272bffe8596853a52c01baa0bdb0b6b0c0bb303
DIST pytest-flakes-4.0.4.tar.gz 7271 BLAKE2B aee9b573c1d4e173465d8547a568433eec3a6ab93a05c1a7655d7ecfd3dff2628f50b4f13f2aaa9a8f3ff365552f54cd1a5a3e4c7b347b056615e136fc5c5657 SHA512 f3bc82bef2dad4a1bf145179f1d25330adcb123cb6e2dd9802b0696be56ef66a8c705725a4e05a9fbbdc37d7482af7fe615735e0e94055f66b0893cc4cf15e53
diff --git a/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch b/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch
deleted file mode 100644
index 35b4809c865b..000000000000
--- a/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-From: Arthur Zamarin <arthurzam@gentoo.org>
-Date: Fri, 27 Aug 2021 08:23:16 +0300
-Subject: [PATCH] test_syntax_error: fix for python 3.10
-
-Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
---- a/test_flakes.py
-+++ b/test_flakes.py
-@@ -20,7 +20,8 @@ for x in []
- pass
- """)
- result = testdir.runpytest("--flakes", "--ignore", testdir.tmpdir)
-- assert "1: invalid syntax" in result.stdout.str()
-+ assert ("1: invalid syntax" in result.stdout.str() or
-+ "1: expected ':'" in result.stdout.str())
- assert 'passed' not in result.stdout.str()
-
-
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
deleted file mode 100644
index d3a52d73420f..000000000000
--- a/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Collection of small Python functions & classes"
-HOMEPAGE="https://pypi.org/project/pytest-flakes/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_tests pytest