summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-04-13 13:50:00 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-04-13 13:53:37 +0200
commit7632117bca502095edd33b7e6793ac200f78927d (patch)
tree4a4c96f110d3084d84222395c3a041c891c2cfb6 /dev-python
parentmedia-sound/lollypop: Remove 1.2.33 (diff)
downloadgentoo-7632117bca502095edd33b7e6793ac200f78927d.tar.gz
gentoo-7632117bca502095edd33b7e6793ac200f78927d.tar.bz2
gentoo-7632117bca502095edd33b7e6793ac200f78927d.zip
dev-python/humanize: bump to 2.3.0
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-2.3.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 853c490b2b18..2e118f282ab6 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,4 @@
DIST humanize-0.5.1.tar.gz 20507 BLAKE2B 55d7b598b32658b1d4c4741b37b5c33bdc9d63a5a779455e2fb93e1e4c3a0d8fd58e8522ef82734e1ba2b161fd881829373ba3569baffd9ea3271ad7ed3e7568 SHA512 dd7ad7f3c564cc6abcb6b128e50dbea7f19f7f418bfd936aae2472961c53ec71202133c5c2b5b930ef41ef807b51d6ba1210565627ed32c0b41acc0abd32a2d5
DIST humanize-2.1.0.tar.gz 38484 BLAKE2B 482ef77b004be1c122bec036dc38d93deda7f714d0384804b9374d7031109e74ec1fbe3bb0fa8e7b28f8c98ccad9a11757a64c765d0ec05e7f031f4cb7d6ee96 SHA512 1efd1c34febf6140a02f15b73a90f453630b255414e056c75fd77c83e9aaa30f802a845b7e1c4e90baf0da26fa6d258e0d0fd84f0d4660b55730baccfde62b2d
DIST humanize-2.2.0.tar.gz 42776 BLAKE2B 9df295b7b34bfb12ca132837e16f0ac2affe1e51ef7bfa533501200fd738967bcabc1b27c37a5fcd7301b6f22a7385a36ec4b30314a099202692d59222a1b271 SHA512 d36a92c7552193eb0fa0aa827041811a77239c067d8070895ed5fbfd05b6f9b4124ac53658d316bf9068256be1b9d7ee61b206209ebc17b6eb24cd70b8ae2461
+DIST humanize-2.3.0.tar.gz 44892 BLAKE2B 70422658e6234d846779b421eda42ff350156f5308a459bb72986f464a4848cefdf10de73b6e13c820a1ad8ea6a82b229b037ec21417c6e98ddada25c2763fc6 SHA512 4e789f3bc0df23db7838efd121f125399fc3601d0b1984f9c134b6b73d1cfb55b8821ebf9f30ad849dae4aa618e7adf3751666487ad2f2c7a9e19273c972eda1
diff --git a/dev-python/humanize/humanize-2.3.0.ebuild b/dev-python/humanize/humanize-2.3.0.ebuild
new file mode 100644
index 000000000000..4785489816a4
--- /dev/null
+++ b/dev-python/humanize/humanize-2.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# The package uses pkg_resources to determine its version
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # The package uses pkg_resources to determine its version
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}