summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:28:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:28:05 +0300
commit7702e0eecdcc2303760a578219a56942193600b6 (patch)
treee6d1ab68556cf48cdbfb3874002039d3152de387 /dev-python
parentdev-python/jaraco-text: add 3.8.1 (diff)
downloadgentoo-7702e0eecdcc2303760a578219a56942193600b6.tar.gz
gentoo-7702e0eecdcc2303760a578219a56942193600b6.tar.bz2
gentoo-7702e0eecdcc2303760a578219a56942193600b6.zip
dev-python/jaraco-functools: add 3.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-functools/Manifest1
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-3.5.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/Manifest b/dev-python/jaraco-functools/Manifest
index 53908829dddc..e98baca0d44c 100644
--- a/dev-python/jaraco-functools/Manifest
+++ b/dev-python/jaraco-functools/Manifest
@@ -1 +1,2 @@
DIST jaraco.functools-3.5.0.tar.gz 13254 BLAKE2B 9165f901106278da562c6b59c3cc29e0b1c4689c5db7955f57a76fca3c12e90d30a80a7dde3420a719b093c41b889e54170bfa6f6f18b6f078e3f4291e59736f SHA512 7257f41506f90ca2fda1bd12fed58fa4d4ff5738547f8cdae8ccad1901e0c818afb701dd8e9050fc77ca1271bc2466d5a542990138bc3db2cf9b04d12850844c
+DIST jaraco.functools-3.5.1.tar.gz 14516 BLAKE2B d58ca0e51767278988f418a5b1b736dd56da2c0ed214fa9b9b2a8b5e4ae77fcdedd431e444d1d2c3359b52a648ec85d01b8b7a2db872bb27d9bf24484347b7a0 SHA512 4496c80eae72834e5bc214f40de91a6aa603ce296b3866e0b363014c2919843f515efe9b314f18667e6b09d183a0985760e47f3340aed42dfbdba01884896df5
diff --git a/dev-python/jaraco-functools/jaraco-functools-3.5.1.ebuild b/dev-python/jaraco-functools/jaraco-functools-3.5.1.ebuild
new file mode 100644
index 000000000000..b3fdabf55095
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-3.5.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/more-itertools-0.12.0-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.functools"
+ version = "${PV}"
+ description = "Functools like those found in stdlib"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}functools-${PV}.dist-info || die
+}