summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-13 09:51:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-13 11:05:50 +0200
commit776814772362ff6b21256647280d2241ce6aea84 (patch)
treef057e70f516b56631c4885eaba5ee6caa9cfb6ea /dev-python
parentdev-python/jupyter_client: Remove 6.1.13 (broken) (diff)
downloadgentoo-776814772362ff6b21256647280d2241ce6aea84.tar.gz
gentoo-776814772362ff6b21256647280d2241ce6aea84.tar.bz2
gentoo-776814772362ff6b21256647280d2241ce6aea84.zip
dev-python/dask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.2.0.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 7b5ddfbf9297..23e2205f7e0e 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1 @@
-DIST dask-2021.2.0.tar.gz 3643277 BLAKE2B d34f706cefd068e42b32c84b05a46c24c98ba8391358140e2a7d2325d3a18cd855fbe9174ac8b8541e8274b83621fcb5c299d70fa5e2bcfe11214a2a32a82ce5 SHA512 da8baaa7cd211eb3ff123127aa9f599337c3af52f06e9a35331397ab580500dda7135addbfe27815a2b14957f7852d9c22a21b1d220af28c8561edaaabdf2e34
DIST dask-2021.3.0.tar.gz 3672035 BLAKE2B 17b3e808603b8524e96273ad33b69689605707a1c187b32c8ed67f054e7f242525365956800017ad5685e0c306dcd21bcfb3dbb3f9920446f03553ceb0fdd9a8 SHA512 ba5b62dd51dad29a106a4fe38a5015f7e1d7ad11eaa21a524b7c8b7d916873b9e447d065c9009e8100662aa3b1f64718b164369f173fc84f5f085a1e369e091a
diff --git a/dev-python/dask/dask-2021.2.0.ebuild b/dev-python/dask/dask-2021.2.0.ebuild
deleted file mode 100644
index bf04a92fdf3f..000000000000
--- a/dev-python/dask/dask-2021.2.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
-HOMEPAGE="https://dask.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
- >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
- >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/toolz[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/numexpr[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- pytest -vv -m "not network" ||
- die "Tests failed with ${EPYTHON}"
-}