summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 07:43:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 08:25:31 +0200
commit77818a7e9d6b072ed49fc8ad8b1416556fb3276a (patch)
tree32f952812ffa678bfab20ed655c48eee6ebedf03 /dev-python
parentdev-python/mediafile: Bump to 0.8.0 (diff)
downloadgentoo-77818a7e9d6b072ed49fc8ad8b1416556fb3276a.tar.gz
gentoo-77818a7e9d6b072ed49fc8ad8b1416556fb3276a.tar.bz2
gentoo-77818a7e9d6b072ed49fc8ad8b1416556fb3276a.zip
dev-python/botocore: Bump to 1.21.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.34.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f3627fc5d685..723a34a1f762 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,4 +10,5 @@ DIST botocore-1.21.30.tar.gz 8081027 BLAKE2B 6566d74873c08ce84f6bd0e6a802e62c6cf
DIST botocore-1.21.31.tar.gz 8081621 BLAKE2B 78bd0ad2d1371582e97c8ddddb9a0b9f41fd75d701ba2ad49fab0e6f3d4602eb6a06bb51f23f674ef71d8c0bcec39ab545071ec8ef252df1c9d9133d8223a746 SHA512 bdaa85ad59936334e8d0e57a0e6631bb1c4408a0b9a50eb883b9b9dc5df4845da2df0fc64af755c5bb2ce5ee667c449a751263e25c9912bcb335eaa41cbba95e
DIST botocore-1.21.32.tar.gz 8083411 BLAKE2B f43cffb2b8dba99e9d893dc6842593525a5545878b52680f8418f86f01f1804dfd1439087092a71d1d9933b63e09615c781e52be8eb5176fb18d1808f0125d18 SHA512 a6d8ca645c3b00b04579be86febd232eac8929f1b58582948208d5b1cc82686c76327302c7459123be8e7a44bece1249ece58fe47619082916e383c0ee6c11a9
DIST botocore-1.21.33.tar.gz 8091142 BLAKE2B 832df8535696227ccd0cfbe16d6084048b5d409f117a1142d97296107466371782ff20d8bd3fbf3bd8a90fe5c23e3b746e55a99014c7203dd5c7c1c1b17fbbb8 SHA512 6618f6b53664a62d10b5edd1845880655e88ff8ef7ed2b35ac0a9b18f0135302d148c12cdc6e588f25a328ac8da5e88174873a021078e8be3dc542da7e1579a8
+DIST botocore-1.21.34.tar.gz 8092134 BLAKE2B ab1ee884adf9dd69883482fe774aeea9f9485cdebcb8d45539b3f1909662f1b4c2eb6041594155acc29e3a90fb4b32cf13eb2f528cb19f27ea3b970e50d2492e SHA512 eece9a9aa9286bea196c576136d7191e712aa500081401d65d5dc6e293c95b8ba8ffb73d1708d62c551a936f5816e1bba0084d8bb5d99e18d4a27ee77392d5ed
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
diff --git a/dev-python/botocore/botocore-1.21.34.ebuild b/dev-python/botocore/botocore-1.21.34.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.34.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}