summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-15 08:43:22 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-15 10:37:50 +0200
commit7883320f6f37eb5af296acee250a7e557eda8f35 (patch)
treeb3f24e651d09434d2c8aef55bfd1531d542f379a /dev-python
parentdev-python/hpack: Remove unnecessary pytest-xdist dep (diff)
downloadgentoo-7883320f6f37eb5af296acee250a7e557eda8f35.tar.gz
gentoo-7883320f6f37eb5af296acee250a7e557eda8f35.tar.bz2
gentoo-7883320f6f37eb5af296acee250a7e557eda8f35.zip
dev-python/hyper-h2: Enable tests
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hyper-h2/hyper-h2-3.0.1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild b/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild
index 9bf1fd6ffd19..0c67c2fa3c2a 100644
--- a/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild
+++ b/dev-python/hyper-h2/hyper-h2-3.0.1.ebuild
@@ -13,7 +13,8 @@ SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/hyperframe-5.0.0[${PYTHON_USEDEP}]
@@ -24,4 +25,12 @@ RDEPEND="
$(python_gen_cond_dep '<dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' python2_7)
"
DEPEND="${RDEPEND}
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
"
+
+python_test() {
+ pytest -vv test || die "Tests fail with ${EPYTHON}"
+}