summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-20 20:59:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-20 20:59:39 +0100
commit78e777c3a28a311d5e33306a0ca6a526d0425390 (patch)
treecda5b5b5f87ee2956c2b895cc9adae7637344e07 /dev-python
parentdev-python/GitPython: Stabilize 3.1.27 ALLARCHES, #833801 (diff)
downloadgentoo-78e777c3a28a311d5e33306a0ca6a526d0425390.tar.gz
gentoo-78e777c3a28a311d5e33306a0ca6a526d0425390.tar.bz2
gentoo-78e777c3a28a311d5e33306a0ca6a526d0425390.zip
dev-python/GitPython: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/GitPython/GitPython-3.1.26.ebuild78
-rw-r--r--dev-python/GitPython/Manifest2
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.26.ebuild b/dev-python/GitPython/GitPython-3.1.26.ebuild
deleted file mode 100644
index ea39973c3411..000000000000
--- a/dev-python/GitPython/GitPython-3.1.26.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-${PV}
-GITDB_P=gitdb-4.0.9
-SMMAP_P=smmap-5.0.0
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # upstream reverted the changes needing py3.10's typing module
- # but did not update the dep
- sed -i -e '/typing-extensions/d' requirements.txt || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- git config --global user.email "travis@ci.com" || die
- git config --global user.name "Travis Runner" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- git rev-parse HEAD > .git/refs/remotes/origin/master || die
- TRAVIS=1 ./init-tests-after-clone.sh || die
- cat test/fixtures/.gitconfig >> ~/.gitconfig || die
- sed -i -e '/addopts/d' pyproject.toml || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # performance tests are unreliable by design
- test/performance
- # unimpoortant and problematic
- test/test_installation.py
- # Internet
- test/test_repo.py::TestRepo::test_leaking_password_in_clone_logs
- # TODO
- test/test_submodule.py::TestSubmodule::test_base_rw
- test/test_submodule.py::TestSubmodule::test_root_module
- )
-
- epytest
-}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 1c8c59e04c54..0809505e17a2 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,5 +1,3 @@
-DIST GitPython-3.1.26.gitbundle 9711896 BLAKE2B 31c06bc713cabe11f0a1cb5fe0a94dbca628cc047de3ac29d83eb97370ebe112aae813ab93717618d4382f13a63bd9cc79709e493c99f77c7d0a2a505181e869 SHA512 99ea5bf310e5edb36f02b44b07729041c683bd1eea1b7af278d6a89147a0761c04aa6eeafbd488b1c84935d00ebf47e7c6230984a8caaccdeccd8c3878b094e4
-DIST GitPython-3.1.26.tar.gz 191901 BLAKE2B 365defa1947719273319bbf8b035710b6bfcecae19d5a8f452d4667b4227f1a5bce4238ff9377b2ac97eee27de97410b19882072b5b6673ec6a75638bd9c8751 SHA512 dcaa14b5bafb6d41c0d5afd57494146b309bcd9a7c65ed4ce56f71fc6e2399640147fac7319dd91b8ea4ae1ca38d02885d5a4b64eccb043c4b8a4347e27a1ecb
DIST GitPython-3.1.27.gitbundle 9652508 BLAKE2B f81b6d94b302b1d4aec85096bb294df1a6a699eff4dd27a1d32083e73b031daf3ef58ec6aa6f98c7693ef187b21de9ea242fa37a88b1f51c0e17238dda978c5c SHA512 bf1011a765b51eb871f6b6a462c693e4e79bb0ba81103d4f268b780b86ab12112c44f74c1d68e93388d1f86c068f6c2336f33ea12dce2e0b2302c940ebb9c49f
DIST GitPython-3.1.27.tar.gz 192188 BLAKE2B 3cab995a17d8eca8d4301367b1ee7a2c3c0a46a217f6e6d89e1bb4e62b733d21cd6d9210faac49c3c905343067e819f8c37ac9cc69d9fc33ce948b63fd53714e SHA512 6f855bcfc380c1a83a97807ca8ddcc4dfe8258f3aba0790142ef41f28befff44847aec925e523eaac47fd6c0078eb6296f52bb4b7d2be7d59ad95bbeb930fe28
DIST gitdb-4.0.9.gitbundle 1461448 BLAKE2B dad9efdc4e9711361c851f4745df2e3fa3b2360ab58cffea971a854429cf3e11862a267efb5afa3d9ff7668dc6d1bb7f11aa033172238bea61a6252d0488b746 SHA512 eb71e6dd380e67a96a9dcd50a3a3c82aab8c7f85b1ca4258a92202a5e4cb5a1535363599c94ab26884b4cd755ce30694c1b193a95e5cd5199b5d4e2cf8e72818