summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 09:05:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 09:21:21 +0200
commit7a9268be4bcba43f3206b51da598312a105dd0dd (patch)
tree1e7a62416a92210067da857819e1ad3fcc797ba5 /dev-python
parentdev-python/QtPy: Revert "x86 stable wrt bug #782481" (diff)
downloadgentoo-7a9268be4bcba43f3206b51da598312a105dd0dd.tar.gz
gentoo-7a9268be4bcba43f3206b51da598312a105dd0dd.tar.bz2
gentoo-7a9268be4bcba43f3206b51da598312a105dd0dd.zip
dev-python/QtPy: Revert "allow dependency to be satisfied by pyside2"
The lot of USE dependencies break pkgcheck, plus the any-of logic is wrong and does not match what the package does. If PyQt5 is installed at all, the package will default to using it even if the dependencies are satisfied by pyside2. Reverts: 8bdd53a2d42010f0ec8f83273938a62195bfbcd5 Bug: https://bugs.gentoo.org/790764 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/QtPy/QtPy-1.9.0-r3.ebuild107
-rw-r--r--dev-python/QtPy/metadata.xml17
2 files changed, 0 insertions, 124 deletions
diff --git a/dev-python/QtPy/QtPy-1.9.0-r3.ebuild b/dev-python/QtPy/QtPy-1.9.0-r3.ebuild
deleted file mode 100644
index e707c30eebb6..000000000000
--- a/dev-python/QtPy/QtPy-1.9.0-r3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..8} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets"
-HOMEPAGE="https://github.com/spyder-ide/qtpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-IUSE="
- declarative designer gui help location multimedia network
- opengl positioning printsupport qml quick sensors serialport
- sql svg test testlib webchannel webengine websockets
- widgets x11extras xml xmlpatterns
-"
-
-# Webengine is a special case, because PyQt5 provides this in a
-# separate package , while PySide2 ships it in the same package
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles
-# the bindings for qml and quick in one flag: declarative,
-# PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally,
-# the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport
-# support unconditionally, the flag is added anyway with a (+)
-# to make it future proof if the ebuild were to change this
-# behaviour in the future.
-#
-RDEPEND="
- app-eselect/eselect-QtPy
- || (
- dev-python/PyQt5[${PYTHON_USEDEP},designer?,gui?,help?,location?,multimedia?,network?,opengl?,positioning?,printsupport?,sensors?,serialport?,sql?,svg?,testlib?,webchannel?,websockets?,widgets?,x11extras?,xml(+)?,xmlpatterns?]
- dev-python/pyside2[${PYTHON_USEDEP},designer?,gui?,help?,location?,multimedia?,network?,opengl(+)?,positioning?,printsupport?,sensors?,serialport(+)?,sql?,svg?,testlib?,webchannel?,websockets?,widgets?,x11extras?,xml?,xmlpatterns?]
- )
-
- webengine? ( || (
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-python/pyside2[${PYTHON_USEDEP},webengine]
- ) )
-
- qml? ( || (
- dev-python/PyQt5[${PYTHON_USEDEP},declarative]
- dev-python/pyside2[${PYTHON_USEDEP},qml]
- ) )
-
- quick? ( || (
- dev-python/PyQt5[${PYTHON_USEDEP},declarative]
- dev-python/pyside2[${PYTHON_USEDEP},quick]
- ) )
-
- declarative? ( || (
- dev-python/PyQt5[${PYTHON_USEDEP},declarative]
- dev-python/pyside2[${PYTHON_USEDEP},qml,quick]
- ) )
-"
-
-# These bindings are currently only provided by PyQt5 or PySide2
-# but not by both. Just DEPEND on these directly if they are
-# required.
-# Please check periodically if this list is still up to date
-#
-# bluetooth? ( dev-python/PyQt5[${PYTHON_USEDEP},bluetooth] )
-# dbus? ( dev-python/PyQt5[${PYTHON_USEDEP},dbus] )
-# examples? ( dev-python/PyQt5[${PYTHON_USEDEP},examples] )
-# networkauth? ( dev-python/PyQt5[${PYTHON_USEDEP},networkauth] )
-# ssl? ( dev-python/PyQt5[${PYTHON_USEDEP},ssl] )
-# webkit? ( dev-python/PyQt5[${PYTHON_USEDEP},webkit] )
-#
-# 3d? ( dev-python/pyside2[${PYTHON_USEDEP},3d] )
-# charts? ( dev-python/pyside2[${PYTHON_USEDEP},charts] )
-# concurrent? ( dev-python/pyside2[${PYTHON_USEDEP},concurrent] )
-# datavis? ( dev-python/pyside2[${PYTHON_USEDEP},datavis] )
-# scxml? ( dev-python/pyside2[${PYTHON_USEDEP},scxml] )
-# script? ( dev-python/pyside2[${PYTHON_USEDEP},script] )
-# scripttools? ( dev-python/pyside2[${PYTHON_USEDEP},scripttools] )
-# speech? ( dev-python/pyside2[${PYTHON_USEDEP},speech] )
-
-# The QtPy testsuite skips tests for bindings that are
-# not installed, so here we ensure that everything
-# is available and all tests are run.
-BDEPEND="test? (
- dev-python/PyQt5[${PYTHON_USEDEP},bluetooth,dbus,declarative,designer,gui,help,location,multimedia,network,networkauth,opengl,positioning,printsupport,sensors,serialport,sql,ssl,svg,testlib,webchannel,webkit,websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-python/pyside2[${PYTHON_USEDEP},3d,charts,concurrent,datavis,designer,gui,help,location,multimedia,network,opengl(+),positioning,printsupport,qml,quick,script,scripttools,scxml,sensors,serialport(+),speech,sql,svg,testlib,webchannel,webengine,websockets,widgets,x11extras,xml,xmlpatterns]
-)"
-
-distutils_enable_tests pytest
-
-python_test() {
- export QT_API="pyqt5"
- virtx pytest -vv
- export QT_API="pyside2"
- virtx pytest -vv
- unset QT_API
-}
diff --git a/dev-python/QtPy/metadata.xml b/dev-python/QtPy/metadata.xml
index 582ff9f96b87..1ad412dcb92f 100644
--- a/dev-python/QtPy/metadata.xml
+++ b/dev-python/QtPy/metadata.xml
@@ -19,30 +19,13 @@
Basically, you can write your code as if you were using PySide2 but import Qt modules from qtpy instead of PySide2 (or PyQt5)
</longdescription>
<use>
- <flag name="declarative">Pull in bindings for the QtQml/QtQuick modules and enable the qmlscene plugin</flag>
<flag name="designer">Pull in bindings for the QtDesigner module and enable the designer plugin</flag>
<flag name="gui">Pull in bindings for the QtGui module</flag>
- <flag name="help">Pull in bindings for the QtHelp module</flag>
- <flag name="location">Pull in bindings for the QtLocation module</flag>
- <flag name="multimedia">Pull in QtMultimedia and QtMultimediaWidgets modules</flag>
- <flag name="network">Pull in bindings for the QtNetwork module</flag>
<flag name="opengl">Pull in bindings for the QtOpenGL module</flag>
- <flag name="positioning">Pull in bindings for the QtPositioning module</flag>
<flag name="printsupport">Pull in bindings for the QtPrintSupport module</flag>
- <flag name="qml">Pull in QtQml module</flag>
- <flag name="quick">Pull in QtQuick and QtQuickWidgets modules</flag>
- <flag name="sensors">Pull in bindings for the QtSensors module</flag>
- <flag name="serialport">Pull in bindings for the QtSerialPort module</flag>
- <flag name="sql">Pull in bindings for the QtSql module</flag>
<flag name="svg">Pull in bindings for the QtSvg module</flag>
<flag name="testlib">Pull in bindings for the QtTest module</flag>
- <flag name="webchannel">Pull in bindings for the QtWebChannel module</flag>
<flag name="webengine">Pull in QtWebEngine and QtWebEngineWidgets modules</flag>
- <flag name="websockets">Pull in bindings for the QtWebSockets module</flag>
- <flag name="widgets">Pull in bindings for the QtWidgets module</flag>
- <flag name="x11extras">Pull in bindings for the QtX11Extras module</flag>
- <flag name="xmlpatterns">Pull in bindings for the QtXmlPatterns module</flag>
- <flag name="xml">Pull in QtXml module</flag>
</use>
<upstream>
<remote-id type="github">spyder-ide/qtpy</remote-id>