summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-12 18:52:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-12 19:33:57 +0200
commit7af0756aec174995658c85e854fac956fafc01c5 (patch)
treeac887d35cbdab551e24ec9008213a713ecf6e504 /dev-python
parentdev-python/botocore: Bump to 1.24.38 (diff)
downloadgentoo-7af0756aec174995658c85e854fac956fafc01c5.tar.gz
gentoo-7af0756aec174995658c85e854fac956fafc01c5.tar.bz2
gentoo-7af0756aec174995658c85e854fac956fafc01c5.zip
dev-python/boto3: Bump to 1.21.38
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.38.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8e73d9e25c4e..54854e075549 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.21.32.tar.gz 485694 BLAKE2B da6fa6f38b234af9e67bfeb8182751f1ac533a2
DIST boto3-1.21.35.tar.gz 486835 BLAKE2B 167070bf09785bac17083cef3caf144cf11a4266c4476af2f6e19b06c81f2d2bcee42b8c7de1d1c9ac178c025bcac08366b2c7cb072cdb663910d45f7e8369fa SHA512 fe73111a46fb27d9c77abec3a13c5267243b2fcc3f89c01d9036f6ca9f362d029c9cbfbb6c1df11b302a9fb0468453fc1b91ee3dac4853bab6662f1ebfa211b2
DIST boto3-1.21.36.tar.gz 487111 BLAKE2B c812e80a2bd81f2feda25b9e43444d1587eb2706ab4372a71f6aad5051020dc2439c639e04f37322ab0c1a396c22c5dc45e773cf73518886d3aab9980633f45c SHA512 1530cd11471ddfdd6a77a250fc5af7546a760cc281b327be6b67b7e49ab40cdc440d4fbe8a72387009b2c2c3dc2e6d7baaa3b1dec3d5d4d276db89e1312e55cf
DIST boto3-1.21.37.tar.gz 487557 BLAKE2B 1c716a07279ce2c1020faee9e2e81b2bde3ed6e4c56668fa76eabc03c7c0818f8dc3ac0fcef66d4007d892e1f227e8642757b6fa5d6e1e18184ad17a30a0e404 SHA512 512e7859e700a98aa3112e21bbd7653e39e7e21bc8f3ef623254322f18869bc9b8a65612a3a9133847c189c59b1e2480225b71bdebd38b2e42cf4820d7ab6972
+DIST boto3-1.21.38.tar.gz 487786 BLAKE2B c247f51e3a7a7f9c531ab18d0fa93b90881c869631bffe35be5482a463a6580e733915d4f966d5700cf6bd822676416e9431f261fd237cb9dd85440308399e2d SHA512 a1b09de7a1dbede4000d500d96028a9ae70c60aa0cc1fc74201d52bc76a83dc27937d422592985e22b3dd1b98359255e837f66f51bae59f2104b379bfa7e49b3
diff --git a/dev-python/boto3/boto3-1.21.38.ebuild b/dev-python/boto3/boto3-1.21.38.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.38.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}