summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-03 23:37:07 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-05 13:55:25 +0200
commit7c43f3153f726f05ae946a61afbf834ba5261be5 (patch)
tree26899f79e676c61b3f5bc4372535560ab8691953 /dev-python
parentdev-python/gpep517: Mark ALLARCHES (diff)
downloadgentoo-7c43f3153f726f05ae946a61afbf834ba5261be5.tar.gz
gentoo-7c43f3153f726f05ae946a61afbf834ba5261be5.tar.bz2
gentoo-7c43f3153f726f05ae946a61afbf834ba5261be5.zip
dev-python/spotipy: new package; add version 2.19.0
Bug: https://github.com/deepjyoti30/ytmdl/issues/222 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/metadata.xml13
-rw-r--r--dev-python/spotipy/spotipy-2.19.0.ebuild48
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
new file mode 100644
index 000000000000..12c83ee2269b
--- /dev/null
+++ b/dev-python/spotipy/Manifest
@@ -0,0 +1 @@
+DIST spotipy-2.19.0.tar.gz 102703 BLAKE2B bc132edb972236b43097c0bbc9d86932a3305d8bd3807e44e20767b123455950b8e01060efd83c87b3a162e329f5c48614205f131686af7f9312a44894a7f1e7 SHA512 fbaecd1a2cab3ef458d30de46cb89462021dfc3cfc85516d8bfe509af016a0b19af2f8de4f5cae36188b1ce1f5718c75edff0e71af2a87f4d720ee99d4541a6a
diff --git a/dev-python/spotipy/metadata.xml b/dev-python/spotipy/metadata.xml
new file mode 100644
index 000000000000..d6cea39e5dcb
--- /dev/null
+++ b/dev-python/spotipy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/plamere/spotipy/issues/</bugs-to>
+ <remote-id type="github">plamere/spotipy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/spotipy/spotipy-2.19.0.ebuild b/dev-python/spotipy/spotipy-2.19.0.ebuild
new file mode 100644
index 000000000000..91857474e8f3
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.19.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A light weight Python library for the Spotify Web API"
+HOMEPAGE="https://spotipy.readthedocs.io"
+SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Requires user credentials
+ rm tests/integration/test_user_endpoints.py || die
+
+ # Requires a spotify client ID
+ rm tests/integration/test_non_user_endpoints.py || die
+
+ # Needs internet access
+ sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
+ tests/unit/test_oauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}