summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 09:53:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 09:54:54 +0100
commit7cc39a6b9dabb79c3b0dd22bf13b2796817ca658 (patch)
tree75a90a2fb0086bdd19b2c82428e8458ef5896c0a /dev-python
parentdev-python/ipython: Remove old (diff)
downloadgentoo-7cc39a6b9dabb79c3b0dd22bf13b2796817ca658.tar.gz
gentoo-7cc39a6b9dabb79c3b0dd22bf13b2796817ca658.tar.bz2
gentoo-7cc39a6b9dabb79c3b0dd22bf13b2796817ca658.zip
dev-python/jsonschema: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonschema/Manifest3
-rw-r--r--dev-python/jsonschema/jsonschema-4.16.0.ebuild56
-rw-r--r--dev-python/jsonschema/jsonschema-4.17.0.ebuild57
-rw-r--r--dev-python/jsonschema/jsonschema-4.17.1.ebuild57
4 files changed, 0 insertions, 173 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 895916ee55f8..42b7cff4e019 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,4 +1 @@
-DIST jsonschema-4.16.0.tar.gz 292399 BLAKE2B b1a78bc7dbc7cd10324638b57ebe4593afbdcbeb8d4b247aa127f41d5f6cce5e7970f5db1576e6a761357d8efe453ef514ae49f58b6624a05c4b7771daff3721 SHA512 c84abc992f410e9d558e2ce06c7172e9e2d298cff469baf8a23b1ea5b4777e6addfa757c5cc62b2e28e257721ee55e04bec0852e5f525adfa87392cbf712828f
-DIST jsonschema-4.17.0.tar.gz 293414 BLAKE2B 51910903a788c5fc0fea695f40ac26c886a88a6b97e653452d11ca9b4cbe18a24fe4c28a13705f77c16c1b2342f66ac86232f9ac7c578c94f23b725580e82b17 SHA512 a0160caea26527e5afbba48fea7f0700e8cd0bb5cbd9661501d34f5dd9857971ca3fd9982bc17f570d0b5a08eb5ecfd0e5182f78a0e0a6343621ed8360643166
-DIST jsonschema-4.17.1.tar.gz 296586 BLAKE2B 2d29abd1d27c216cb53363ea801f1a83aedfae66fc1cf90dd7b9cb4e9ce809e09819585a7e83c060dadc2a200c45036ec22cd35d4005757b4b8797f05daa207b SHA512 5d184ea60cf313c9fa6a3e1c2891432531aa7a25a5aced8e51aac46eb67fe7fd17bc9d141faa3e52a834f9067556225cfd3a592d80867b543f0dea42983e5d04
DIST jsonschema-4.17.3.tar.gz 297785 BLAKE2B a0383bf5612ae50e94c95dbc1774d796b62c74a7aae3056a40edb7e042ad07fd7885e61d86220120a906a4017afe30d8ee8edbbf0cf01a6dec1f212984ff1c1e SHA512 626fc913c37d2e49e4b47c9e058aab4a96c1dc50c35d8def0b2ea0ca464dc25e3318d4fde4927c11ca38068743cd81779d5189464b821407ac1de1788bad30e2
diff --git a/dev-python/jsonschema/jsonschema-4.16.0.ebuild b/dev-python/jsonschema/jsonschema-4.16.0.ebuild
deleted file mode 100644
index a450048b34a1..000000000000
--- a/dev-python/jsonschema/jsonschema-4.16.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="
- https://pypi.org/project/jsonschema/
- https://github.com/python-jsonschema/jsonschema/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
- dev-python/pkgutil_resolve_name[${PYTHON_USEDEP}]
- ' 3.8)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
-"
-
-# formatter deps
-RDEPEND+="
- dev-python/fqdn[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/isoduration[${PYTHON_USEDEP}]
- >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
- dev-python/rfc3339-validator[${PYTHON_USEDEP}]
- dev-python/rfc3986-validator[${PYTHON_USEDEP}]
- dev-python/rfc3987[${PYTHON_USEDEP}]
- dev-python/uri_template[${PYTHON_USEDEP}]
- >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires pip, does not make much sense for the users
- jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
- # wtf?
- jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
- jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
-)
diff --git a/dev-python/jsonschema/jsonschema-4.17.0.ebuild b/dev-python/jsonschema/jsonschema-4.17.0.ebuild
deleted file mode 100644
index ac11d050d26a..000000000000
--- a/dev-python/jsonschema/jsonschema-4.17.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="
- https://pypi.org/project/jsonschema/
- https://github.com/python-jsonschema/jsonschema/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
- dev-python/pkgutil_resolve_name[${PYTHON_USEDEP}]
- ' 3.8)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
-"
-
-# formatter deps
-RDEPEND+="
- dev-python/fqdn[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/isoduration[${PYTHON_USEDEP}]
- >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
- dev-python/rfc3339-validator[${PYTHON_USEDEP}]
- dev-python/rfc3986-validator[${PYTHON_USEDEP}]
- dev-python/rfc3987[${PYTHON_USEDEP}]
- dev-python/uri_template[${PYTHON_USEDEP}]
- >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires pip, does not make much sense for the users
- jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
- # fragile warning tests
- jsonschema/tests/test_deprecations.py
- # wtf?
- jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
-)
diff --git a/dev-python/jsonschema/jsonschema-4.17.1.ebuild b/dev-python/jsonschema/jsonschema-4.17.1.ebuild
deleted file mode 100644
index ac11d050d26a..000000000000
--- a/dev-python/jsonschema/jsonschema-4.17.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="
- https://pypi.org/project/jsonschema/
- https://github.com/python-jsonschema/jsonschema/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
- dev-python/pkgutil_resolve_name[${PYTHON_USEDEP}]
- ' 3.8)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
-"
-
-# formatter deps
-RDEPEND+="
- dev-python/fqdn[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/isoduration[${PYTHON_USEDEP}]
- >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
- dev-python/rfc3339-validator[${PYTHON_USEDEP}]
- dev-python/rfc3986-validator[${PYTHON_USEDEP}]
- dev-python/rfc3987[${PYTHON_USEDEP}]
- dev-python/uri_template[${PYTHON_USEDEP}]
- >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires pip, does not make much sense for the users
- jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
- # fragile warning tests
- jsonschema/tests/test_deprecations.py
- # wtf?
- jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
-)