summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-21 19:53:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-21 19:53:16 +0300
commit7d3d3a2a19e309600ad3d97c9a453968fc9b5727 (patch)
tree32953e509cba5cb24f2a8fc7ffe558dc2b2cdc97 /dev-python
parentdev-python/rcssmin: add github upstream metadata (diff)
downloadgentoo-7d3d3a2a19e309600ad3d97c9a453968fc9b5727.tar.gz
gentoo-7d3d3a2a19e309600ad3d97c9a453968fc9b5727.tar.bz2
gentoo-7d3d3a2a19e309600ad3d97c9a453968fc9b5727.zip
dev-python/rcssmin: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rcssmin/rcssmin-1.0.6.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/rcssmin/rcssmin-1.0.6.ebuild b/dev-python/rcssmin/rcssmin-1.0.6.ebuild
index 1161a3a5cbef..515bb03be054 100644
--- a/dev-python/rcssmin/rcssmin-1.0.6.ebuild
+++ b/dev-python/rcssmin/rcssmin-1.0.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -15,8 +15,11 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-DOCS=""
python_install_all() {
distutils-r1_python_install_all
mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
}
+
+python_test() {
+ "${EPYTHON}" run_tests.py tests || die "Tests failed with ${EPYTHON}"
+}