summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 07:43:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 07:47:22 +0200
commit7edf27e4e303137c49926eeb30f4586baac5ce03 (patch)
treefcf1ea7d2b94000861cc3843fa80859dc0402f0b /dev-python
parentdev-python/pyglet: Bump to 1.5.20 (diff)
downloadgentoo-7edf27e4e303137c49926eeb30f4586baac5ce03.tar.gz
gentoo-7edf27e4e303137c49926eeb30f4586baac5ce03.tar.bz2
gentoo-7edf27e4e303137c49926eeb30f4586baac5ce03.zip
dev-python/beautifulsoup: Bump to 4.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/beautifulsoup/Manifest1
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index f253159b19c1..4dede2d8d2dd 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1 +1,2 @@
+DIST beautifulsoup4-4.10.0.tar.gz 399890 BLAKE2B 61f044064a81e94b64a72fd49cca164faa05442bc76f897c8a7fa4481acca039bcb9e4f7a1853a7155504fa25e56c518806d8af016369bc37316ecb95b59d7d3 SHA512 92be99ed0fd479b86519395143516e28f7b80f54a8251223d6e7b88dc98f8dfca9585079f5f1d89bfe68f577de3dff433711642486303203f46bc76754959a18
DIST beautifulsoup4-4.9.3.tar.gz 376031 BLAKE2B fbe2139f288eee978c3f665c7640f66c6c51b857a186f6a8ace02b36effa1552f1cbea9e3744e0a46a65a06e6cdbd9203832e0ecd86b61406b933f9bd83d37b8 SHA512 e3cb6258bd7c51f12128fa8ee5948fb3566163ae233fac2dda21bab7772ab8dbb384d920b0ea138ef9921307b48f89cee3a9bf6111dfc8903d917ee7af365f34
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild
new file mode 100644
index 000000000000..90b5dd8cdfb7
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx doc/source