summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-08-09 11:33:41 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-09 11:20:02 +0200
commit80a91d5e06d922d0d1c341dc69abda7cf87ae512 (patch)
treea115ab91490499d5d93230f8f0f966b12aa91f6d /dev-python
parentdev-python/treq: enable py3.10, enable tests (diff)
downloadgentoo-80a91d5e06d922d0d1c341dc69abda7cf87ae512.tar.gz
gentoo-80a91d5e06d922d0d1c341dc69abda7cf87ae512.tar.bz2
gentoo-80a91d5e06d922d0d1c341dc69abda7cf87ae512.zip
dev-python/treq: cleanup dependencies
Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/treq/treq-21.5.0.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/treq/treq-21.5.0.ebuild b/dev-python/treq/treq-21.5.0.ebuild
index f81142924b6e..74917bd68d0a 100644
--- a/dev-python/treq/treq-21.5.0.ebuild
+++ b/dev-python/treq/treq-21.5.0.ebuild
@@ -17,23 +17,17 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
-COMMON_DEPEND="
- dev-python/incremental[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
>=dev-python/hyperlink-21.0.0[${PYTHON_USEDEP}]
-"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/twisted-18.7.0[crypt,${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
>=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7.0[crypt,${PYTHON_USEDEP}]
"
-
-DEPEND="${COMMON_DEPEND}
+BDEPEND="
doc? ( dev-python/sphinx
${RDEPEND} )
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/httpbin[${PYTHON_USEDEP}]
)"
@@ -49,5 +43,5 @@ python_install_all() {
python_test() {
distutils_install_for_testing
- "${EPYTHON}" trial treq || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" -m twisted.trial treq || die "Tests failed with ${EPYTHON}"
}