summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 07:49:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 08:27:55 +0200
commit822162a89de52ed76da7a94b4592729a81a8701d (patch)
treec5dc8d90c80d6c267b430966af16fb67ecaeb090 /dev-python
parentapp-misc/rundeck-cli-bin: unkeyword 2.0.1 for ~amd64 (diff)
downloadgentoo-822162a89de52ed76da7a94b4592729a81a8701d.tar.gz
gentoo-822162a89de52ed76da7a94b4592729a81a8701d.tar.bz2
gentoo-822162a89de52ed76da7a94b4592729a81a8701d.zip
dev-python/pikepdf: Bump to 5.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-5.4.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 408b758befd2..d5f844b07c21 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -1,3 +1,4 @@
DIST pikepdf-5.2.0.gh.tar.gz 2359546 BLAKE2B 953a5268eb7dc52934967b593237bb3006ee35e7a1657c0721ef4cdc874c9c51d7920fbdb7e38f67e221b01536166b8811a95021668491e8c783f51a08f49144 SHA512 f36ec09017aeac547c2b4ef17de7513293e8bf243707cb9c0c03826973be266847d8514002be546ac958a735e29765df94efdaecde6ad5f901c329dadc3e9451
DIST pikepdf-5.3.1.gh.tar.gz 2360816 BLAKE2B 02b36814144acbf05cf50d8bca6542271208af0ed7548dd8f41493b6e95183851033a3d4f3335f10d4bf6798606e9031aa2b38d28a9e824692fe8f78f1e68077 SHA512 b0256533011dae384ce657200db69b6e3ac93b4364fe55a2e0fb8fb2d993550dcfe4e05b723b81d62ed1db3cd544023e81a9e70fd807bcfb618f125ae5a35117
DIST pikepdf-5.3.2.gh.tar.gz 2886857 BLAKE2B 343006c8123bd814a93d1863442e9fdf80d93ae020ae6b4471cbae640653e74f3652c7c3e32d2e5ec68f5425f24a34543c0d712d78320d46db9bdb8db64ce1bb SHA512 3586a8f33550698d9b49852d741ebea7fd06e3afdbd7f1ed74ba7d9f8bbc086ff35ed964dd065f1e764f6690b3a708440eee97857591829a565acf2f0702ae33
+DIST pikepdf-5.4.0.gh.tar.gz 2891493 BLAKE2B 12aec9e7fe22c9e372886bdf3c32d509f13a92fe0526469445f801ecb3b92d8fb27ad817bee6fc1845a3057d6fe56cfde5712907e9a89fc16412a1528e988504 SHA512 5be5f1d79a4fb9119aa4aed8fd4e0d02f53a7affe39c8b019aad3717b20ec303e8dbd3ac19d57e099c591ea7a29cbaf786b40d5235850f756bc17fe5335324fd
diff --git a/dev-python/pikepdf/pikepdf-5.4.0.ebuild b/dev-python/pikepdf/pikepdf-5.4.0.ebuild
new file mode 100644
index 000000000000..0dcfce946c36
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-5.4.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="
+ https://github.com/pikepdf/pikepdf/
+ https://pypi.org/project/pikepdf/
+"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-text/qpdf-10.6.2:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/-n auto/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}