summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-29 23:49:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 00:14:55 +0100
commit831d3cdf3639aa7dd708f262ed594d8736e6d033 (patch)
tree26846a22f1c74bf7e275600bd60f3e450fa5185f /dev-python
parentdev-python/virtualenv: Bump to 20.11.2 (diff)
downloadgentoo-831d3cdf3639aa7dd708f262ed594d8736e6d033.tar.gz
gentoo-831d3cdf3639aa7dd708f262ed594d8736e6d033.tar.bz2
gentoo-831d3cdf3639aa7dd708f262ed594d8736e6d033.zip
dev-python/huawei-lte-api: Bump to 1.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index 427075993def..a59d2f9b5958 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1 +1,2 @@
DIST huawei-lte-api-1.5.2.tar.gz 31969 BLAKE2B ced0afc9c1b878d30ac4d3fb731cdebd6c2a658a7ace7d74f5e3641c049d5eaeab5fe1edd4678b791da0ebd22c78c4c7b10f56e2bb4f224788d1f1cdd8f31c6a SHA512 7d7b8b0248ef6080aa990ce06e196653f315605d771c312c490976cd950dfa962affe47f8df3366a645e0d499606514618e1e24976f434258ca22bd9ccf34237
+DIST huawei-lte-api-1.5.4.tar.gz 32433 BLAKE2B 36ba5729f7016c07955f87b85745314f683345e06e174efa90e2fdfd59a8a68c8425b549f8e25293dc2d65d0681a588feb062c3067b275d4e0ed2b56dc3ebbb6 SHA512 549373bf6d00aa1fb3f9f6443446520e068ec2c5412c84472b687102b2590cd22a742805f8c7fab67b7a4482e37cb3b03900aaf078ed777c3b1c111194e69da6
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild
new file mode 100644
index 000000000000..9f84cd2c71a0
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.5.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="https://github.com/Salamek/huawei-lte-api"
+SRC_URI="https://github.com/Salamek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest