summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-05 09:10:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-05 09:52:59 +0200
commit8445ccbca899f97426f026a05762b7e95cfee84d (patch)
treee671141db8e8eecc43493ed959c2fcb1d67f04ca /dev-python
parentdev-python/ipykernel: Bump to 6.12.1 (diff)
downloadgentoo-8445ccbca899f97426f026a05762b7e95cfee84d.tar.gz
gentoo-8445ccbca899f97426f026a05762b7e95cfee84d.tar.bz2
gentoo-8445ccbca899f97426f026a05762b7e95cfee84d.zip
dev-python/nbformat: Bump to 5.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 3b6e18b20bec..ce2b9c372541 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,2 +1,3 @@
DIST nbformat-5.1.3.gh.tar.gz 130922 BLAKE2B 866eb53dd3f04c09f4a08303c5e84b672cc826d2d9b369cd85038b6c4075e74dce88fbcae80fc9b5450faf1c4971d121abe35e0a2ce2a8e73e020d2bed3a5594 SHA512 b4bc3d51d6e940ce1e2b1f5ca1005cf3d466b2b7b589383a31c4d2908c4e539344f4c8fb9e92993469d4d66f363c35082f0c16b8a63aa61e19fb24fa5ac910fd
DIST nbformat-5.2.0.gh.tar.gz 133519 BLAKE2B aa9ff18ff879fe4b85af6d552a7d2f44d10bb96366e7af15214f7ae4c9d193a24bee8d0dc0ae1b71da13f44abaf4093e412f32b8357b4846985940c002a17b7e SHA512 55718e84a5125f8c28c8cd1be0725669f4d56bc22e6dd92b907a0e8cda27e17f8f56aad29806ee9f1c2c58641dd80455f04241fe5a54f8b6309575bb7656fc87
+DIST nbformat-5.3.0.gh.tar.gz 133531 BLAKE2B 7d4e0fdee7c2b5cfdb09bf90ff225b6be184cb6e02e36319e52c5a021283b2ae884c189f1e98a9fd40f1e12811bafe37cc59d27f1e34433d38c00e5fb0cc9fbe SHA512 50cb0b98501c2ee640ae1e6036346912ebc58f63faa8f1e4535681eb3f468072d5bc462d3788cc4233108612239fe03a1da41acfe30c915e13e7428f35415a91
diff --git a/dev-python/nbformat/nbformat-5.3.0.ebuild b/dev-python/nbformat/nbformat-5.3.0.ebuild
new file mode 100644
index 000000000000..b21a6cd7e450
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="
+ https://github.com/jupyter/nbformat/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest