summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-06 09:07:09 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-06 09:12:13 -0500
commit84561a865909a6e205d2b7b7e0692e20e1f3cd08 (patch)
tree0a70cb06119e631166c2de09361aef6d7f6dd459 /dev-python
parentdev-python/cached-property: Version bump (diff)
downloadgentoo-84561a865909a6e205d2b7b7e0692e20e1f3cd08.tar.gz
gentoo-84561a865909a6e205d2b7b7e0692e20e1f3cd08.tar.bz2
gentoo-84561a865909a6e205d2b7b7e0692e20e1f3cd08.zip
dev-python/docker-py: add version 1.9.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-1.9.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index 052c79b4dfbf..f3c74eea3e84 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1,4 +1,5 @@
DIST docker-py-1.2.2.tar.gz 69685 SHA256 85284a5b1a965e01a5d0a91f9f639ad5069143a276c123198fdafc3659280b38 SHA512 bf00b19e0ab56e5c0e8459234d09722ca504ecd933bfba61cb4ab4805410f53f6ad6083f2e964ef5a6eded2ea05aa01a89c27621064386bae145c7258ed996ad WHIRLPOOL bd7ff4579f924e02d18581b1aca00790dcb84afda03e4cde70b349bfdb4ad43aa2e06da2bcbe780f6074d98f9af9b14fb9d2ab4da9265e56b73288902c9ede7a
DIST docker-py-1.8.0.tar.gz 102575 SHA256 6a2feb4dad94ff01401af1bd1455ca20505af4bb5439f1c80114020461c4cf58 SHA512 60ac793d3061aec4fe46c694a00207560138895c7c6299a6734f2413601648da5130db00dbf33f41c3a91a717d825b9d1ce76413df2ae433b30a61eead373b39 WHIRLPOOL e5e204e7754fe5b038ef218718063892661636bd4ce51a160479725562865076ae2a3c99c38721b7c4f184ba45390f4c5a28582b83311af81da67867cf05a643
DIST docker-py-1.8.1.tar.gz 101171 SHA256 82dc8db8088576ec5c42c203f7c46a88a26963e137ee0dafbf7e33882d75eb47 SHA512 c05412a43a774cc402e8f1bbb6c389c17e7fc335db4cfbe2d8a7001d7389f74fe51b3a2120bbbde640d93c5788283651b992389e3a09852eecb10e87e13466a0 WHIRLPOOL 47bdb88c07385d98cf5922ee420f85a93a84c62cc807acd9b0093ce55c386a4bd9f3cca1603e00259d32b0c3f0617282c49f23e4f67ead803a1ea5850ddeafc3
+DIST docker-py-1.9.0.tar.gz 105939 SHA256 0ff58798c8cf79c7e459505786b3b83ca0552a077945b8fe20fc38ff3f732361 SHA512 49e6d4e8ab30c4e54165e7eff9e3034a1fe102348020bad2c5aefa238c44efdf39711536a7727fd9689e2e90483a348930bb91f1e76cade546161c82990f78ed WHIRLPOOL d60bca034f91569f37bef65ff42fcf950dfbc02bc42053bb650a9188661a8c0d9c21cb03128782a15799e6f208e88b32618286615ef94ba9396a4940ae3b6603
DIST docker-py-1.9.0_rc2.tar.gz 105689 SHA256 30770466eef8fe5db3ac75ede506bb412de8a59600954089b385b4d134d54051 SHA512 8c4993aea477ae640660d10f80ca0a9b5f40f1d7a446cc67d392b824c78272ee32d42004952a70a3a55a105f313c06338266b206f4193cab736fa84c3c9b4d8c WHIRLPOOL bf1329f20095d519756a68bc3bd2a95d6d476366e1cfdc38eb38a6ad4a25da11964a20d039fb32af69dd4bd76b578b43b3b6b468767ba2fc8305b088019ae17c
diff --git a/dev-python/docker-py/docker-py-1.9.0.ebuild b/dev-python/docker-py/docker-py-1.9.0.ebuild
new file mode 100644
index 000000000000..0ff1887b3644
--- /dev/null
+++ b/dev-python/docker-py/docker-py-1.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
+ test? (
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ ~dev-python/pytest-2.7.2[${PYTHON_USEDEP}]
+ ~dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_3' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+
+python_compile_all() {
+ if use doc; then
+ mkdocs build -d 'mkdocs_site' || die "docs failed to build"
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ | die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( mkdocs_site/. )
+
+ distutils-r1_python_install_all
+}