summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-18 17:07:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-18 17:33:42 +0200
commit8603f6637a8b21cab43a89ff70edf5dfd8cc2907 (patch)
tree524bbc14d692a353cfe234771668c2893982f588 /dev-python
parentsci-libs/linux-gpib: Remove old (diff)
downloadgentoo-8603f6637a8b21cab43a89ff70edf5dfd8cc2907.tar.gz
gentoo-8603f6637a8b21cab43a89ff70edf5dfd8cc2907.tar.bz2
gentoo-8603f6637a8b21cab43a89ff70edf5dfd8cc2907.zip
dev-python/distlib: Readd, new dep of virtualenv
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/distlib/Manifest1
-rw-r--r--dev-python/distlib/distlib-0.3.0.ebuild51
-rw-r--r--dev-python/distlib/metadata.xml7
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/distlib/Manifest b/dev-python/distlib/Manifest
new file mode 100644
index 000000000000..4bbb3b2204aa
--- /dev/null
+++ b/dev-python/distlib/Manifest
@@ -0,0 +1 @@
+DIST distlib-0.3.0.tar.bz2 848089 BLAKE2B 70f88b570229e2ab4c95bd8da0375aba189f66dec8defcf8eedf1be6924d93bd20b54c68e5fba867a6c68a31d4ef926ee2dc18ccb0391278680f30a62d0cd251 SHA512 01b0e7d59736414a241efdf883e4ee63eafe9614ce3b4147781a5750d25d6383543146c5277e3e0d3e11ce03693afd0331c6e3416776a6f84de7a4d9dadf3de4
diff --git a/dev-python/distlib/distlib-0.3.0.ebuild b/dev-python/distlib/distlib-0.3.0.ebuild
new file mode 100644
index 000000000000..867d3b72eb37
--- /dev/null
+++ b/dev-python/distlib/distlib-0.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level components of distutils2/packaging"
+HOMEPAGE="https://pypi.org/project/distlib/
+ https://bitbucket.org/pypa/distlib/"
+# pypi has zip only :-(
+SRC_URI="
+ https://bitbucket.org/pypa/distlib/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # this test assumes pristine venv with no system packages
+ sed -e 's:test_dependency_finder:_&:' \
+ -i tests/test_locators.py || die
+ # no clue but it looks horribly fragile
+ sed -e 's:test_sequencer_basic:_&:' \
+ -i tests/test_util.py || die
+ # TODO: investigate
+ sed -e 's:test_upload:_&:' \
+ -i tests/test_index.py || die
+ # these require Internet
+ sed -e 's:test_search:_&:' \
+ -i tests/test_index.py || die
+ sed -e 's:test_aggregation:_&:' \
+ -e 's:test_all:_&:' \
+ -e 's:test_dist_reqts:_&:' \
+ -e 's:test_json:_&:' \
+ -e 's:test_prereleases:_&:' \
+ -e 's:test_scraper:_&:' \
+ -i tests/test_locators.py || die
+ sed -e 's:test_package_data:_&:' \
+ -i tests/test_util.py || die
+ # doesn't work with our patched pip
+ sed -e '/PIP_AVAIL/s:True:False:' \
+ -i tests/test_wheel.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/distlib/metadata.xml b/dev-python/distlib/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/distlib/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>