summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-22 06:30:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-22 06:46:33 +0200
commit882e93c3f21aea784ebd45d0940f14614cf2106f (patch)
tree177b77efc39e0be9be8c5faadcaf7ce399f38417 /dev-python
parentdev-python/hypothesis: Bump to 5.15.1 (diff)
downloadgentoo-882e93c3f21aea784ebd45d0940f14614cf2106f.tar.gz
gentoo-882e93c3f21aea784ebd45d0940f14614cf2106f.tar.bz2
gentoo-882e93c3f21aea784ebd45d0940f14614cf2106f.zip
dev-python/six: Bump to 1.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/six-1.15.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 6da6ad3d6253..3015599c7eeb 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1 +1,2 @@
DIST six-1.14.0.tar.gz 33857 BLAKE2B 711ef5b79118c1280c9868688869cc475668c248e6b0c2061145818842d5b4c28809d86b1388709af24f6e92fe5926ea6261f1b85c62db749f79664cbad93e4d SHA512 4dea0f4e7961e8b582d665501c65852dc3b73516a0b6f78b0888c8670f1450df58bd3eea418777f41080b842ab6c3d8633be1034bcf920192e5590d5316e2c9e
+DIST six-1.15.0.tar.gz 33917 BLAKE2B 57e852b6c35dd19e256814c0371cfbc26141b0f25a31f79a1cbd1b0cdd7d3cacf1236b96f5452f968cc426e6dff4d1ad70a9f2432bc361ba3c8c17fd40fe7582 SHA512 eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9
diff --git a/dev-python/six/six-1.15.0.ebuild b/dev-python/six/six-1.15.0.ebuild
new file mode 100644
index 000000000000..fce9c6eaf047
--- /dev/null
+++ b/dev-python/six/six-1.15.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+distutils_enable_sphinx documentation --no-autodoc
+distutils_enable_tests pytest