summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-05 00:30:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-05 10:36:36 +0100
commit8871de46d56b0f3b5c981718073af27a3f095ab8 (patch)
tree983b527088598f9ea8e1ee8e26bf603b99a7faa1 /dev-python
parentdev-python/logilab-common: Clean old up (diff)
downloadgentoo-8871de46d56b0f3b5c981718073af27a3f095ab8.tar.gz
gentoo-8871de46d56b0f3b5c981718073af27a3f095ab8.tar.bz2
gentoo-8871de46d56b0f3b5c981718073af27a3f095ab8.zip
dev-python/lxml: Clean old up
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/lxml/Manifest2
-rw-r--r--dev-python/lxml/lxml-4.0.0.ebuild80
-rw-r--r--dev-python/lxml/lxml-4.1.0.ebuild80
3 files changed, 0 insertions, 162 deletions
diff --git a/dev-python/lxml/Manifest b/dev-python/lxml/Manifest
index 6e2c33f121e1..2f9a639b1f22 100644
--- a/dev-python/lxml/Manifest
+++ b/dev-python/lxml/Manifest
@@ -1,4 +1,2 @@
DIST lxml-3.8.0.tar.gz 3795205 BLAKE2B 39f3edc7efe48bd569b636de89cfcd8f7e4e88e025fd5c21164e35edf110546112844a4ddb6cb1842649fb165de3b3880b0fdb7a23522a891b35390adf64c95b SHA512 08f6f352e22ed2bc199a5f34a1c6b5f7b41ec282dc0026c9f16a06466c27e39e8eb18608ba4493636170eeac4b0194f7050445e1cc9bd0a4628573c404593088
-DIST lxml-4.0.0.tar.gz 4217301 BLAKE2B 812c67f0769c9b72e6fcd641ff61821255c7a3036213f4dbc82683e9bd4b94096e44c4af6d9091623e0fa7cccc6286561d3a9947fdeace45100af640e417073d SHA512 8aa85ab6a99097ae2eaa0087b3a663aae8ac81a0a4d685bf857571c811c8ccd6410afc414f14c68702a53e90265726af085d0609ec7f0d3cc96e3702772627e8
-DIST lxml-4.1.0.tar.gz 4247102 BLAKE2B 650e7ca2961e4552f0ca29d81043f44b672c39d07d54d5072b6ac4218c5d43a00ecb79341a2d678ddf35885df224b8afa1ec8bc6b6e4faa46a42e545b1a44cce SHA512 c4a1180a119ec2d21ab29d00cf60e72ca38a2c28eca4f221251d0fd1c481650fe78ec975532c38a6a59c441bb6f6469bbb110b6b0e9d6b6fffd68dbcad90fcb6
DIST lxml-4.1.1.tar.gz 2380804 BLAKE2B 4d3c4ef0472c7af7bb4185142a8274b596dd55a908d41f5295d0a78031a7efb3aef8893ca739f8db0675e44d4b0c346746a2758d31a54825c06a153203599ab9 SHA512 9542e5206f9b2f9e072c52ef8e6cf44d1aaae8ae3e7ca7e820c1fac12e716503308ccb3cebc52155b4c93799f3ebca247781fc491524d004378bd26f5cddb9d1
diff --git a/dev-python/lxml/lxml-4.0.0.ebuild b/dev-python/lxml/lxml-4.0.0.ebuild
deleted file mode 100644
index 2ab0055cd819..000000000000
--- a/dev-python/lxml/lxml-4.0.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="http://lxml.de/ https://pypi.python.org/pypi/lxml/ https://github.com/lxml/lxml"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD ElementTree GPL-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads test"
-
-# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
-RDEPEND="
- >=dev-libs/libxml2-2.9.2
- >=dev-libs/libxslt-1.1.28"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
- "
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5.0-cross-compile.patch
-
- # This patch removes a testcase that fails because of issues
- # in libxml2.
- #
- # Upstream bug: https://bugs.launchpad.net/lxml/+bug/1608479
- "${FILESDIR}"/${PN}-3.6.4-fix-test_xmlschema.patch
-)
-
-python_prepare_all() {
- # avoid replacing PYTHONPATH in tests.
- sed -i '/sys\.path/d' test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if [[ ${EPYTHON} != python3* ]]; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
- tc-export PKG_CONFIG
- distutils-r1_python_compile
-}
-
-python_test() {
- cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
- cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
- ln -s "${S}"/doc "${BUILD_DIR}"/ || die
-
- "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- local DOCS=( *.txt doc/*.txt )
- local HTML_DOCS=( doc/html/. )
- fi
- if use examples; then
- docinto examples
- dodoc -r samples/.
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
- optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
-}
diff --git a/dev-python/lxml/lxml-4.1.0.ebuild b/dev-python/lxml/lxml-4.1.0.ebuild
deleted file mode 100644
index 2ab0055cd819..000000000000
--- a/dev-python/lxml/lxml-4.1.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="http://lxml.de/ https://pypi.python.org/pypi/lxml/ https://github.com/lxml/lxml"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD ElementTree GPL-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads test"
-
-# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
-RDEPEND="
- >=dev-libs/libxml2-2.9.2
- >=dev-libs/libxslt-1.1.28"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
- "
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5.0-cross-compile.patch
-
- # This patch removes a testcase that fails because of issues
- # in libxml2.
- #
- # Upstream bug: https://bugs.launchpad.net/lxml/+bug/1608479
- "${FILESDIR}"/${PN}-3.6.4-fix-test_xmlschema.patch
-)
-
-python_prepare_all() {
- # avoid replacing PYTHONPATH in tests.
- sed -i '/sys\.path/d' test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if [[ ${EPYTHON} != python3* ]]; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
- tc-export PKG_CONFIG
- distutils-r1_python_compile
-}
-
-python_test() {
- cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
- cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
- ln -s "${S}"/doc "${BUILD_DIR}"/ || die
-
- "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- local DOCS=( *.txt doc/*.txt )
- local HTML_DOCS=( doc/html/. )
- fi
- if use examples; then
- docinto examples
- dodoc -r samples/.
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
- optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
-}