summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-31 23:27:44 +0000
committerSam James <sam@gentoo.org>2021-12-31 23:28:07 +0000
commit88b82ac1a3bcbd09c7d0bd852bc57b8b6431eb54 (patch)
tree93112a1a943e8930dedd892855b371ce219c3c4a /dev-python
parentsys-libs/fts-standalone: minor fixes (diff)
downloadgentoo-88b82ac1a3bcbd09c7d0bd852bc57b8b6431eb54.tar.gz
gentoo-88b82ac1a3bcbd09c7d0bd852bc57b8b6431eb54.tar.bz2
gentoo-88b82ac1a3bcbd09c7d0bd852bc57b8b6431eb54.zip
dev-python/nose_warnings_filters: fix setuptools description
Upstream is dead since 2016 though. Closes: https://bugs.gentoo.org/824990 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch13
-rw-r--r--dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild4
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch b/dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch
new file mode 100644
index 000000000000..de05a2f5d26b
--- /dev/null
+++ b/dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 1f9ac02..829c5e8 100644
+--- a/setup.py
++++ b/setup.py
+@@ -17,7 +17,7 @@ from setuptools import setup
+
+ setup(name='nose_warnings_filters',
+ version='0.1.5',
+- description='Allow to inject warning filters during ``nosetest``.\n\nPut the same arguments as ``warnings.filterwarnings`` in ``setup.cfg``\nat the root of your project. Separated each argument by pipes ``|``, one\nfilter per line. Whitespace are stripped.\n\nfor example:\n\n::\n\n [nosetests]\n warningfilters=default |.* |DeprecationWarning |notebook.*\n ignore |.*metadata.* |DeprecationWarning |notebook.*\n once |.*schema.* |UserWarning |nbfor.*\n error |.*warn.* |DeprecationWarning |notebook.services.contents.manager*\n\nIf you prefer another name for the configuration file, you can tell nose\nto load the configuration using the ``-c`` flag: run the tests with\n``nosetests -c nose.cfg``.\n\ndetails configuration.\n======================\n\nEach line of warning filter is separated in maximum 4 sections, that\nmatch the first 4 sections of ``filterwarnings``:\n\n.. code:: python\n\n filterwarnings(action, message="", category=Warning, module="", lineno=0, append=False)\n\nfields 2 to 4 can be omitted, ie to say 1 line can be of the following\nform:\n\n::\n\n action\n action| message\n action| message | category\n action| message | category | module\n\nthe value of each fields is treated the same as for ``filterwarnigns``\nexcept: - whitespace are trimmed. - if the ``category`` has dots, the\ncorresponding class try to be imported. If it does not have dots, the\nname is looked up in ``builtins`` or ``__builtins__``\n\ntest are failing\n================\n\nFor some reasons in some systems tests are failing; it seem that this\npackage have difficulty to self-test. That\'s likely due to the fact that\nthe tested package need to be in different namespaces, and by\nself-testing we break this assumption.\n',
++ description='Allow to inject warning filters during ``nosetest``',
+ url='https://github.com/Carreau/nose_warnings_filters',
+ author='Matthias Bussonnier',
+ author_email='bussonniermatthias@gmail.com',
diff --git a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
index 46d14c80fd80..eca1dd453d80 100644
--- a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
+++ b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
@@ -16,4 +16,8 @@ KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.5-setuptools-newline-desc.patch
+)
+
distutils_enable_tests nose