summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-24 17:03:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-24 17:03:41 +0200
commit89532757df840b185cac2946734e89ad55cecc3c (patch)
tree298c8e8a3482aa71488299aea2f5fd2d116f7975 /dev-python
parentdev-python/cov-core: Remove old (diff)
downloadgentoo-89532757df840b185cac2946734e89ad55cecc3c.tar.gz
gentoo-89532757df840b185cac2946734e89ad55cecc3c.tar.bz2
gentoo-89532757df840b185cac2946734e89ad55cecc3c.zip
dev-python/hypothesis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.16.3.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 18ac8939a3a7..11c94c78e85b 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,4 @@
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
-DIST hypothesis-python-5.16.3.tar.gz 9011952 BLAKE2B d74a68c4ee1e5aacf4be1da5a4656011b0a15f990106c21298101d36e9a097c5dfd165987ad90a45f3a0b74375c4da609cd750f618242b94f34e03b6de0ee866 SHA512 912d984995d4ad8f06e98eb2cc327629328990fc1c072527ce261b637e16622acaf4d0d93928f9dd2d6601ab78f69aa6cf129d5cd7c1c00e50754ebc06957df0
DIST hypothesis-python-5.21.0.tar.gz 9025422 BLAKE2B acd6f3b0f945ae65656af2a718add06fe440e221fda7793e3557ab194ccee4c6327e7946a58ce51e9efe3c08274888a648d9021c49fdcf663a04c28b99a0f636 SHA512 1921e5ea8d0f2a6e55d80611004d35671f7a7a02cb8a8f101b45e64e4ef23f9c2c8a9c467fb6c9f33ae440622020e1ad504f51a7d725a6449ca715ad1f373e40
DIST hypothesis-python-5.24.3.tar.gz 9050345 BLAKE2B bfb47794edb3c1c6aee22e808a6d27af52f8176d307f9a585efa0f1e0d68adf9a902ed6f67405e77c6804f18e17a76486ab42f610807f6ee97535f950318a055 SHA512 7647d14ba805ad3ff6465e1d2c6d9104560c7ea31517777ab45e07da39efefa7109215d2f4074082620554ae4aa5ce5060bca5c923d11c14718f1efdae829986
DIST hypothesis-python-5.24.4.tar.gz 9054743 BLAKE2B 5c64c86ed58d8f0e4a07390b1b1b5e405878b9632bf14233e0515ad9d98ec6ddcc57bf39be6b61f53739d34e393b3af64c0d362880019d29a649a9523a0204e3 SHA512 147f4fa47b54bf3ec4dfcebf2a6c98cee26ea6780244ef99e181bada65978375ca7731ed05cb98f1b92f7a44a357faae374d97d489ec6e2318ff94e526cd9a40
diff --git a/dev-python/hypothesis/hypothesis-5.16.3.ebuild b/dev-python/hypothesis/hypothesis-5.16.3.ebuild
deleted file mode 100644
index 337791fc8e5e..000000000000
--- a/dev-python/hypothesis/hypothesis-5.16.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
- !!<dev-python/typing-3.7.4.1
- )
-"
-
-src_prepare() {
- # avoid pytest-xdist dep for one test
- sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
- tests/pytest/test_statistics.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -vv tests/cover tests/pytest tests/quality ||
- die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}